Can't register Newsbin using Ubuntu 10.10 & Crossover Linux

While it isn't officially supported, we have many users who successfully run NewsBin under Linux with a Windows emulator (Wine is the most popular). This forum exists for you Linux guys to share your experience getting NewsBin running on Linux as well as report any strangeness that we may or may not be able to fix. DThor is the resident expert.

Moderators: Quade, dexter, newsraider, DThor

Can't register Newsbin using Ubuntu 10.10 & Crossover Linux

Postby barqy » Thu Oct 14, 2010 4:32 pm

Hoping somebody has a solution...

Using latest Ubuntu 10.10
Upto date Crossover Linux
Newsbin 5.58

I created a Windows 2000 bottle (also tried Windows XP), and am able to install Newsbin, but when I go to register, I get the following:

Registration Failed with error Registration Failed - Can't Contact Server.
When I look at the Critical Error Message Log:
ERROR MODULE-InterSocket, MSG=SSL Connection Failed: 0 - Line 499

I have Newsbin working on a Windows XP machine, so I'm not hobbled, but I'd like to migrate over to Linux, and this problem is cramping my style.
barqy
n00b
n00b
 
Posts: 2
Joined: Thu Oct 14, 2010 4:21 pm

Registered Newsbin User since: 01/15/09

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby barqy » Thu Oct 14, 2010 4:40 pm

Going to back down to Ubuntu 10.04 LTS version due to other compatiblity issues. If it remains a problem I'll post back again.
barqy
n00b
n00b
 
Posts: 2
Joined: Thu Oct 14, 2010 4:21 pm

Registered Newsbin User since: 01/15/09

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby DThor » Thu Oct 14, 2010 5:33 pm

Odds are it's a firewall/networking issue. Seems like NB can't get out, there's no particular reason it shouldn't work.

DT
V6 Troubleshooting FAQ . V6 docs. Usenet info at Usenet Tools. Thanks!
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby gkmacs » Fri Oct 15, 2010 2:38 pm

I installed Newsbin just a couple of hours ago and have the same problem with registering. I can run everything else.
I too have Ubuntu 10.10 installed.

Need help!
gkmacs
n00b
n00b
 
Posts: 2
Joined: Tue Mar 13, 2007 3:54 pm

Registered Newsbin User since: 02/03/07

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby dexter » Fri Oct 15, 2010 4:09 pm

Someone else reported the exact same problem to us over technical support. They fixed it saying something in crossover was blocking Newsbin on port 443.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9201
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby DThor » Fri Oct 15, 2010 4:23 pm

A good diagnostic is to install wine and try using it. I've never had such troubles with wine. At least that would tell you where the problem lies, and once you're done uninstalling is as easy as
Code: Select all
'rm -rf ~/.wine'


DT
V6 Troubleshooting FAQ . V6 docs. Usenet info at Usenet Tools. Thanks!
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby Rogue downlowder » Sun Oct 17, 2010 8:11 pm

I have the same problem with ubuntu 10.10 and wine I did notice NBpro said it couldnt change firewall setting during install it didnt surprise me but I am new to lixux and cant find the firewall settings in ubuntu but what does NBpro want to change anyway?

thanks any help appreciated
Rogue
Rogue downlowder
n00b
n00b
 
Posts: 6
Joined: Sun Oct 17, 2010 8:00 pm

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby Rogue downlowder » Sun Oct 17, 2010 8:17 pm

new discovery it works with ssl disabled still wont register but ssl didnt connect at all so now I have few days before it dies
Rogue downlowder
n00b
n00b
 
Posts: 6
Joined: Sun Oct 17, 2010 8:00 pm

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby dexter » Sun Oct 17, 2010 11:03 pm

It needs SSL to finish registration. You know the problem, port 443 is getting blocked. I don't know Ubuntu so I can't help you with firewall settings. Maybe someone else can help if you can't figure it out.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9201
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby jacob733 » Sun Nov 21, 2010 3:22 am

I had the same problem when using wine 1.0. When I switched to Wine 1.2, the problem went away. Now I just have to deal with the shift-delete issue that was introduced in Wine 1.2...
jacob733
Occasional Contributor
Occasional Contributor
 
Posts: 38
Joined: Wed Jan 09, 2002 12:44 pm
Location: Denmark

Registered Newsbin User since: 04/26/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby Redbird » Fri Nov 26, 2010 3:38 pm

Rogue downlowder wrote:I have the same problem with ubuntu 10.10 and wine I did notice NBpro said it couldnt change firewall setting during install it didnt surprise me but I am new to lixux and cant find the firewall settings in ubuntu but what does NBpro want to change anyway?


Forget about the firewall setttings. Should be running (and registering) without it. I'm running without problems on Maverick (with SSL enabled).

I do not remember very well how I setup SSL. It was no very difficult, but not so easy. I installed some SSL related packages, but do not remenber the exact ones. If you continue with problems, I can check which ones are installed.
Redbird
Occasional Contributor
Occasional Contributor
 
Posts: 13
Joined: Fri Sep 10, 2010 5:50 pm

Registered Newsbin User since: 09/10/10

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby Quade » Fri Nov 26, 2010 4:07 pm

Newsbin has the SSL stuff built in so, you shouldn't have to add anything for it to work.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 41977
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby DThor » Sun Nov 28, 2010 10:25 am

Just as an update for you guys, I've started to run a VM to test Linux distros(just for my own nefarious uses ;) ) and I installed the latest/greatest Ubuntu 10.10 as a guest host just a moment ago, I grabbed the generic wine(running 64 bit ubuntu, but I think the default wine is 32, plus I installed the 32 bit Newsbin), and Newsbin installed and ran flawlessly. Registered, downloaded material, the works. I didn't need to fiddle with a single thing, and the system install was with all the defaults as far as security. This goes to show that for the most part:

1. Latest default wine is probably your best option for new distro releases. Try to avoid 3rd party wine wrappers unless you *really* need it. These typically can co-exist, however!

2. If you do feel the need to fiddle/hack/manually override things(well, you *are* Linux users after all :) ), then the highest likelihood for the cause of your grief, assuming the app installs and seems to run OK, but doesn't do anything, is the firewall or similar features built in to whatever wine wrapper you're using. As my experience proves, though, if you just 'follow the rules', things usually just work.

DT
V6 Troubleshooting FAQ . V6 docs. Usenet info at Usenet Tools. Thanks!
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby jacob733 » Sun Nov 28, 2010 10:42 am

Which wine version are you using? Ubuntu includes 2 versions, a stable 1.0 release, and a less stable but more features 1.2 release.

/Jacob
jacob733
Occasional Contributor
Occasional Contributor
 
Posts: 38
Joined: Wed Jan 09, 2002 12:44 pm
Location: Denmark

Registered Newsbin User since: 04/26/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby DThor » Sun Nov 28, 2010 12:21 pm

As mentioned, I did it about as vanilla as you can get - apt-get wine.

DT
V6 Troubleshooting FAQ . V6 docs. Usenet info at Usenet Tools. Thanks!
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby gorgone » Sun Aug 14, 2011 5:22 am

hello i get another error message on registering

i use debian and run newsbin on wine 1.3

if i press the register button than shows me newsbin this message
Code: Select all
Registration Failed with error HTTP/1.1 409 - Key not found in key database


Image
gorgone
n00b
n00b
 
Posts: 2
Joined: Sat Aug 13, 2011 4:56 pm

Registered Newsbin User since: 05/21/11

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby Quade » Sun Aug 14, 2011 8:58 am

Email us. Use the support form on the site. This means it's working and we don't like something about the key you're sending. Make sure you cat and paste the key into place.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 41977
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby DThor » Sun Aug 14, 2011 9:09 am

I don't know how experienced a linux user you are, but keep in mind that while copy/pasting works quite well between most desktop clipboards and wine, you should carefully check the results. You're also using a language with accented characters. In theory it all works perfectly, but if you get frustrated, you might try carefully manually typing it in.

DT
V6 Troubleshooting FAQ . V6 docs. Usenet info at Usenet Tools. Thanks!
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby gorgone » Mon Aug 15, 2011 3:55 am

i try both copy and paste
and type manual

same result

if i paste it on windows no problem :-( thats sad

is there a way to create a reg export from windows and import on linux ?
gorgone
n00b
n00b
 
Posts: 2
Joined: Sat Aug 13, 2011 4:56 pm

Registered Newsbin User since: 05/21/11

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby DThor » Mon Aug 15, 2011 9:54 am

As Quade said, you should contact them. You're talking to the server, it's responding, so it's not a technical problem, if you've carefully entered it, the server thinks it's wrong. Perhaps it thinks you've exceeded your 3 installs? All the more reason to get in touch, they'll sort it out. The 3 install limit is just there to make sure people aren't sharing licenses across the internet, if you are just one over because you neglected to properly uninstall an old system, shouldn't be a problem to get you sorted.

The registry is just a text file in wine, in $HOME/.wine. There's not much difference pasting into that than pasting into the dialogue, I don't think it's worth your time, plus it's easy to pooch your setup. There's no special path to somehow export from windows registry into wine that I'm aware of, I would be a mess, I imagine.

DT
V6 Troubleshooting FAQ . V6 docs. Usenet info at Usenet Tools. Thanks!
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Re: Can't register Newsbin using Ubuntu 10.10 & Crossover Li

Postby newsraider » Mon Aug 15, 2011 2:26 pm

i always copy and paste the code to newsbin to register it on new OS installs and never once had a problem. seems like something else is going on here?
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06


Return to Linux

Who is online

Users browsing this forum: No registered users and 2 guests