Newsbin Pro and Sonarr

Technical support and discussion of Newsbin Version 6 series.

Newsbin Pro and Sonarr

Postby ThisFaceLeftBlank » Sat Oct 01, 2016 10:29 pm

I've successfully ran NBP and Sonarr since April, but due to a issue with a Microsoft Update (anniversary?), I had to format and reinstall. I recall that it was pretty easy to set up the first time, but it's been two days of googling and futzing around, and no joy.

This is one of the things I found via the googles:
viewtopic.php?f=43&t=38181

Very easy and straightforward, and very much not working. At this point, I feel like I could bring in a monkey to fling poo at the monitor and it would be equally as effective towards reaching my objective: I'm just completely lost. Please throw me a bone here. I'd like to get this set up by Monday, as I go in for surgery Tuesday, and I doubt this will get any easier for me after that.

Here is what I'm actually seeing, in case I'm clicking on something wrong.

Image

Image

I'm changing the port entries to match, of course, and I've tried several different ones. Upon following the directions in the post linked to above, I get the following error after testing: "Test was aborted due to an error: Unable to connect to SABnzbd, please check your settings" It doesn't seem to matter if I have SSL enabled or not in Sonarr. I use SSL in NBP in communicating with my Usenet servers.

If I get this fixed, I'm screenshotting it and hardcopying it, I swear.

So many, many thanks in advance for any help.
ThisFaceLeftBlank
Occasional Contributor
Occasional Contributor
 
Posts: 14
Joined: Mon Feb 07, 2011 8:32 am

Registered Newsbin User since: 02/16/11

Re: Newsbin Pro and Sonarr

Postby Quade » Sat Oct 01, 2016 11:34 pm

1 - You need an API key at the very least. Sonarr won't work without one. Just make something up. It has to be the same on both ends.

2 - Is sonarr running on the same machine?

3 - Don't use SSL between Newsbin and Sonarr. If they're running on the same machine, the packets never leave your PC.

4 - You might use "127.0.0.1" instead of "Localhost" on both sides. Localhost is supposed to be a shortcut for that 127 address but I prefer 127...

5 - Make sure both ports are the same.

6 - Might disable you firewall and see if that allows the connection through.

Your specific error suggests a port problem or that you have SSL enabled. I'd use "Netstat -ant" before starting Newsbin and see if something is listening on 8000 already. If it is, use some other unused port. I'd set it in Newsbin, then restart Newsbin and type "Netstat -ant" from a command prompt. You should see something listening on the port you picked.

TCP 0.0.0.0:8000 0.0.0.0:0 LISTENING InHost
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin Pro and Sonarr

Postby ThisFaceLeftBlank » Sun Oct 02, 2016 12:32 am

Well, I messed about and did what you said, and the test function worked. We'll see if i can get any files to DL, though. So far, I haven't been about to get anything to DL. I'll see what happens overnight.

Thanks for the help, much appreciated.
ThisFaceLeftBlank
Occasional Contributor
Occasional Contributor
 
Posts: 14
Joined: Mon Feb 07, 2011 8:32 am

Registered Newsbin User since: 02/16/11

Re: Newsbin Pro and Sonarr

Postby Quade » Sun Oct 02, 2016 9:13 am

If "Test connection" works then it's just a matter of Sonarr sending NZB data to Newsbin. You might see if you can force some NZB's down to Newsbin. They should show up on the download list.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin Pro and Sonarr

Postby depredador » Wed Dec 21, 2016 10:45 pm

I have started having a problem with Sonarr and Newsbin Pro that has only started recently.

Sonarr has always downloaded the NZB and successfully and sent it to Newsbin where it downloads without any probs.

Recently it has started playing up as when the NZB is sent through to Newsbin it is sent through as individual rar files and will not download correctly and unrar. I'll attach a screen shot

Image

Here is the same NZB manually downloaded in Sonarr from a different indexer

Image

The second image is how it's always appeared and worked without any probs but the first one is how some have started recently and I haven't changed any settings.

So what is going wrong and how can I fix it so it starts working again properly?

BTW Sonarr have said it's not a problem with it.

Cheers
depredador
Active Participant
Active Participant
 
Posts: 64
Joined: Sat Sep 20, 2008 11:49 pm

Registered Newsbin User since: 09/25/08

Re: Newsbin Pro and Sonarr

Postby depredador » Wed Dec 21, 2016 10:52 pm

I don't know why I'm getting those messages and my Image isn't appearing?
depredador
Active Participant
Active Participant
 
Posts: 64
Joined: Sat Sep 20, 2008 11:49 pm

Registered Newsbin User since: 09/25/08

Re: Newsbin Pro and Sonarr

Postby Quade » Wed Dec 21, 2016 10:58 pm

They're just random filenames. There's no actual way to group them so, they go as individual files.

As long as the PAR files download they should work. There's someone on our IRC channel that uses that style NZB's and he says they work.

I see the PAR blocks counting up meaning Newsbin is recognizing the files. This isn't a problem as long as Newsbin can rename and unrar the files. The block counts should tell you. This issue isn't sonarr or Newsbin. It's an artifact of both how the files are posted and the search engine you're using to feed Sonarr.

You need to put your Newsbin key into your user profile for the pics to work.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin Pro and Sonarr

Postby depredador » Wed Dec 21, 2016 11:35 pm

Quade wrote:They're just random filenames. There's no actual way to group them so, they go as individual files.

As long as the PAR files download they should work. There's someone on our IRC channel that uses that style NZB's and he says they work.

I see the PAR blocks counting up meaning Newsbin is recognizing the files. This isn't a problem as long as Newsbin can rename and unrar the files. The block counts should tell you. This issue isn't sonarr or Newsbin. It's an artifact of both how the files are posted and the search engine you're using to feed Sonarr.

You need to put your Newsbin key into your user profile for the pics to work.

It's not working for me as each individual rar and par file downloads and sits there but it doesn't unrar.
depredador
Active Participant
Active Participant
 
Posts: 64
Joined: Sat Sep 20, 2008 11:49 pm

Registered Newsbin User since: 09/25/08

Re: Newsbin Pro and Sonarr

Postby Quade » Thu Dec 22, 2016 3:40 am

Watch the PAR counts.

You see where it says "95 of 2019"? You need 2019 PAR blocks to get a complete download. That can be blocks from files or blocks from PARS.

My guess is you're not getting complete downloads.

The second type is a standard obscured download. Looks like nothing has downloaded from it yet.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin Pro and Sonarr

Postby depredador » Wed Apr 05, 2017 1:39 am

So in regards to this https://www.reddit.com/r/usenet/comment ... m/dfti6i2/

Where to email?
depredador
Active Participant
Active Participant
 
Posts: 64
Joined: Sat Sep 20, 2008 11:49 pm

Registered Newsbin User since: 09/25/08

Re: Newsbin Pro and Sonarr

Postby Quade » Wed Apr 05, 2017 9:54 am

ts@newsbin.com

If the problem is what I think it is, missing parts on your server, this NZB might work fine for me.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin Pro and Sonarr

Postby depredador » Sun Apr 09, 2017 10:43 pm

So I sent one NZB a few days ago and haven't had a reply?
depredador
Active Participant
Active Participant
 
Posts: 64
Joined: Sat Sep 20, 2008 11:49 pm

Registered Newsbin User since: 09/25/08

Re: Newsbin Pro and Sonarr

Postby Quade » Mon Apr 10, 2017 8:12 am

Ok I got it. I'll check it out.

It downloaded perfectly for me but then again I expected that. I think it's because I have multiple news servers. It didn't clean up after itself very well.

The next step is for me to damage the NZB a bit to simulate only having a single server missing parts of the file and see if there's a way to make it still work. The NZB's work as long as the first chunk isn't missing. If the first chunk is missing determining what PAR the files belong to becomes difficult because of the obscured filenames.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin Pro and Sonarr

Postby depredador » Mon Apr 10, 2017 8:39 am

I can download it all fine it just does each separately and does not unrar. Same NZB from another indexer does.
depredador
Active Participant
Active Participant
 
Posts: 64
Joined: Sat Sep 20, 2008 11:49 pm

Registered Newsbin User since: 09/25/08

Re: Newsbin Pro and Sonarr

Postby Quade » Mon Apr 10, 2017 10:26 am

I can download it all fine it just does each separately and does not unrar. Same NZB from another indexer does.


When I say perfect, I mean I ended up with a wrongly named MKV file in the unrar path so it worked fine. Download, repair and unrar.

To do a clean download for these kinds of NZB's might require some changes on my end.

I'm still looking and making notes. I'm not clear why they don't partially compact together.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin Pro and Sonarr

Postby depredador » Mon Apr 10, 2017 10:23 pm

I don't know why it's only happening with NZB's from PFMonkey either when they insist there's nothing wrong at their end.
depredador
Active Participant
Active Participant
 
Posts: 64
Joined: Sat Sep 20, 2008 11:49 pm

Registered Newsbin User since: 09/25/08

Re: Newsbin Pro and Sonarr

Postby Quade » Tue Apr 11, 2017 7:31 am

I don't know why it's only happening with NZB's from PFMonkey either when they insist there's nothing wrong at their end.


The reason they don't compact together is because the "Poster" field is randomized. I've been thinking about code changes for the sonarr interface in order to handle this. The NZB's are pretty shitty in that the filenames don't match the filenames of the actual files and the posters are randomized which breaks compaction but they should still work for you. They work for me.

I'd suggest watching the block counts and seeing if the block counts add up properly. If they block counts + repair counts exceed the needed blocks, if should repair and unrar.

The only thing I don't understand is why they download and unrar for me but not for you.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42375
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 4 guests