What happened to my new files?????

Technical support and discussion of Newsbin Version 6 series.

What happened to my new files?????

Postby rassafratz » Fri Jan 06, 2017 6:25 am

My system crashed earlier. and when I restored it the only "already set up newsbin" I had was a copy of 6.52.

So I restored my "C:\program files\newsbin" and my "C:\Documents and Settings\Mikey\Local Settings\Application Data\Newsbin" directories.

It ran fine and I downloaded a few moxnix files just to test it but it didn't "feel" like the 6.6 I was used to before the crash.

So I upgraded this to 6.72, and behold, there was the familiar layout I was used to.

Now I decided to do an experiment. Only 2 of my servers were setup to download headers, and I reset it so that all 4 did, and then I proceeded to download all groups from all servers. (yeah I know, groups are not headers - I'm just telling you what I did in the order I did it)

And so I continued:

Now back when I had 6.6 I had my groups separated into 3 newsbin "folders": "prime", "primeII" and "others".

But my 6.52 had all my groups "up front" so to speak.

So I created a new "prime" folder and moved some of my favorite groups to it and added a couple of others that I found in my newly downloaded groups.

And now is when the fun begins:

I highlighted all the files in the "prime" folder and selected "download all headers".

Hours later it was finished, the "new files" column was filled with 5 and 6 digit numbers, and I saw that my HD space had shrunk from 48 gigs free to 19.5 gigs free, and likewise my "spool_v6" had swelled from 12.8 gigs to over 37 gigs

So now I did a boolean search for a term on this folder and came back with just under 197K hits.

And so I decided to "save" this search in an NZB file.

And this is where the program jumped down the rabbit hole:

About halfway through, the damned thing kept "BONGING" at me with a message box saying "newsbin50" (say WUT?!?!?) and that I was "out of memory".

I couldn't kill the damned thing, it just REBONGED at me. I finally had to kill newsbin using task manager.

And then I turned around and open newsbin again.

And my new "prime" folder was gone.

And none of the newsgroups were registering new files, and the 2 newly added groups were showing the default "never" in the "new files" column. All the others were "0".

HOW-FREAKING-EVER...my HD STILL only has 19.5 gigs free (which CLEARLY indicates 28 or so gigs of SOMETHING is using up space on my HD somewhere - and it damned sure isn't in my "recycle bin".

And yet my spool_v6 is back to its original 12.8 gigs.


So the question is, WTF happened to my downloaded headers and my "prime" folder?


BTW and FWIW, the 2 files I newly subscribed to are still subscribed. They're just in the "root" of my "groups list" instead of being inside my now non-existent "prime" folder. But the headers I downloaded for them (like all the rest) are nowhere to be found.

Also BTW and just for kicks, I just duplicated the search I mentioned earlier which netted me 197K hits, and I only got 120,488 hits.
rassafratz
Occasional Contributor
Occasional Contributor
 
Posts: 27
Joined: Sat Nov 02, 2013 6:52 am

Registered Newsbin User since: 10/28/13

Re: What happened to my new files?????

Postby Quade » Fri Jan 06, 2017 11:26 am

1 - It crashed so it couldn't do any exit book-keeping. Meaning it couldn't save the "New" count or the groups settings.

2 - All the headers are still there.

Re-do what you did, exit and restart Newsbin if you want to make sure your settings are saved. The only thing that sounds like a potential bug is the crash and generating NZB's. Someone else reported it too but I've not managed to reproduce it.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 41754
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: What happened to my new files?????

Postby rassafratz » Fri Jan 06, 2017 1:17 pm

Quade wrote:1 - It crashed so it couldn't do any exit book-keeping. Meaning it couldn't save the "New" count or the groups settings


I could accept that in principle (and in fact I guess I'll have no choice but to do that), but after creating the aforementioned "prime" folder and moving groups to it, I specifically searched the "prime" folder for files and newsbin appeared to perform that.

It's annoying that newsbin would be able to USE my new settings without having saved them.

2 - All the headers are still there.


Apparently not, since I got 197K hits after the downloads but only 120K hits on the same search after the crash. Moreover, the 120K was across ALL the groups (since my "prime" folder no longer existed) while the 197K was from just the groups in the "prime" folder alone when it did exist.

Thanks for the response anyway. Just register my grumbling and I'll have to get over it.
.
rassafratz
Occasional Contributor
Occasional Contributor
 
Posts: 27
Joined: Sat Nov 02, 2013 6:52 am

Registered Newsbin User since: 10/28/13

Re: What happened to my new files?????

Postby Quade » Fri Jan 06, 2017 3:17 pm

1 - The "Storage Age" controls how many days of headers are stored so, depending on the setting you might have purged off some of the headers.

2 - If you look down at the "Cache" display, if you see a number in parens "(XXX)" then that means all the headers haven't imported yet.

3 - Options are saved as soon as you close the options window. On the other hand things like making new groups of groups and moving groups into the folders are saved on exit.

4 - Most servers have mostly the same content so, downloading headers from multiple servers doesn't necessarily buy you anything.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 41754
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests

cron