Error message when pulling in Supernews headers.

Technical support and discussion of Newsbin Version 6 series.

Error message when pulling in Supernews headers.

Postby crosgrove » Wed Jul 05, 2017 1:58 pm

Got a new problem... Errors when pulling Supernews headers.

The group I am will list a total number of headers to pull. Say, 178,000 and will get to 50,000 / 178,000 and stop dead. Then I get the following error message(s).

[07/05 12:29:42] ERROR Server:Supernews NNTPServer: Compressed Headers - Timeout Waiting for Server to send Data:
[07/05 12:34:51] ERROR Server:Supernews NNTPServer: Compressed Headers - Timeout Waiting for Server to send Data:

Try another group with 340,000 headers. It pulls in fine.

Another group with 8,744/070 headers. Pulls in fine until it hits 1,000,000 and stops dead. Message:

[07/05 12:50:10] ERROR Server:Supernews NNTPServer: Timeout - Waiting for Server to send Data:

But the first million headers appear to have processed. Redo header pull of same group. Stops at 430,000 / 7,744,270 with

ERROR Server:Supernews NNTPServer: Compressed Headers - Timeout Waiting for Server to send Data:

Redo pull of same group, Stops at 430,000 / 7,744,270 with

ERROR Server:Supernews NNTPServer: Compressed Headers - Timeout Waiting for Server to send Data:

Redo pull of same group, Stops at 430,000 / 7,744,270 with

ERROR Server:Supernews NNTPServer: Compressed Headers - Timeout Waiting for Server to send Data:

Repeat over and over.

I know, from past experience *I* probably have some setting set wrong. Anyone have any ideas where I should be tweaking?
crosgrove
Occasional Contributor
Occasional Contributor
 
Posts: 30
Joined: Sat Apr 07, 2007 4:21 pm

Registered Newsbin User since: 04/11/07

Re: Error message when pulling in Supernews headers.

Postby crosgrove » Wed Jul 05, 2017 9:02 pm

Found a fix -- I did 3 things (no idea which one was it, or what combination was it).

1. Switch to SSL server
2. REALLY advanced server options: Disable XFeatures
3. REALLY advanced server options: Use BODY command

Is currently working... at present... for right now...
crosgrove
Occasional Contributor
Occasional Contributor
 
Posts: 30
Joined: Sat Apr 07, 2007 4:21 pm

Registered Newsbin User since: 04/11/07

Re: Error message when pulling in Supernews headers.

Postby dexter » Wed Jul 05, 2017 9:15 pm

Just disabling XFeatures would have fixed this. The issue is your security software is conflicting with Newsbin. Most security software is not expecting to see binary data in an NNTP stream so sometimes it behaves badly because XFeatures is compressed header data. If you want to use XFeatures, you'll have to tell your security software to ignore Newsbin.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9240
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Error message when pulling in Supernews headers.

Postby crosgrove » Wed Jul 05, 2017 10:15 pm

DOH!!!

Next Question -- is there ANY advantage to resetting the other 2 settings back to default?
crosgrove
Occasional Contributor
Occasional Contributor
 
Posts: 30
Joined: Sat Apr 07, 2007 4:21 pm

Registered Newsbin User since: 04/11/07

Re: Error message when pulling in Supernews headers.

Postby Quade » Thu Jul 06, 2017 10:43 am

BODY is slightly faster than ARTICLE. Some servers only support "BODY". That's why it's an option.

The fundamental problem is that your security software is messing with the connections to the news server. That's why XFeatures is failing. XFeatures can download headers 10 times faster than not using it. I'd suggest you make any security software ignore Newsbin's connections to the news server then use XFeatures. Security companies don't know usenet so they can't help but mess up the connections.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42221
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Error message when pulling in Supernews headers.

Postby crosgrove » Thu Jul 06, 2017 12:12 pm

Yep. You nailed it. I am using AVG Free, and disabling the Resident Shield component allows NEWSBIN to operate properly and pull the Supernews headers.

Pretty fast too, I might say.

Now I have to find out how to tell AVG to ignore Supernews. I found one post on that on the AVG site, but the advice offered by tech support appears to have trashed his system and required a re-install of Windows. So, obviously, I am hesitant to follow the AVG advice.

But, ya, that did it and it pulls in headers damn fast now.

As always, thanks!

UPDATE: Putting Newsbin in the exceptions list did not resolve the issue. Putting news.supernews.com in the exceptions list did not resolve the issue either. I think I may be stuck with just disabling AVG for 10 mins when I download headers.

Further update: Disabling EMAIL protection also cured it. I looked in the email options. There is a NNTP scan option in there that by default is on.

WTF??? Who is the coder at AVG that told them that newsgroups and email were the same thing, so bury the NNTP newsfeed scan toggle in there??

Regardless, That resolved the issue. Downloads are screaming fast and I don't have to turn off AVG for 10 minutes when I run the program. WOOHOO!
crosgrove
Occasional Contributor
Occasional Contributor
 
Posts: 30
Joined: Sat Apr 07, 2007 4:21 pm

Registered Newsbin User since: 04/11/07

Re: Error message when pulling in Supernews headers.

Postby Quade » Thu Jul 06, 2017 12:48 pm

Further update: Disabling EMAIL protection also cured it. I looked in the email options. There is a NNTP scan option in there that by default is on.


This is kinda what I meant about them not knowing usenet. Many years ago, Usenet WAS very similar to email. In fact "Posts" to usenet are formatted like emails. 10 or so years ago, email and usenet split though so, things like XFeatures came around which breaks the "email = usenet" assumption.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42221
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Error message when pulling in Supernews headers.

Postby crosgrove » Thu Jul 06, 2017 8:04 pm

Quade wrote:
Further update: Disabling EMAIL protection also cured it. I looked in the email options. There is a NNTP scan option in there that by default is on.


This is kinda what I meant about them not knowing usenet. Many years ago, Usenet WAS very similar to email. In fact "Posts" to usenet are formatted like emails. 10 or so years ago, email and usenet split though so, things like XFeatures came around which breaks the "email = usenet" assumption.



Yah, I mean, I know Usenet is not as large a percentage of Internet traffic that is was say... 20 years ago, but it is still a huge market, and although I am dismayed over the fact a lot of Newsgroups I liked have died because the WWW does serve those interests better, it is still a great place to go for material. The NEWSBIN search server is still my go-to place to find something I really want. It is worth every penny.
crosgrove
Occasional Contributor
Occasional Contributor
 
Posts: 30
Joined: Sat Apr 07, 2007 4:21 pm

Registered Newsbin User since: 04/11/07


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests