6.73 Crashes on show posts

Technical support and discussion of Newsbin Version 6 series.

6.73 Crashes on show posts

Postby Illuminated » Fri Oct 06, 2017 9:42 am

Right click on group, then select "show posts". Progress bar pongs left-right-left-right for a while. Then it fills left to right, getting almost all the way to the right. After a second or two the app just closes.

This is what is in the log file:

[10/06 07:52:28] HIGH PAR Pausing: Enabled
[10/06 07:52:28] HIGH Par2Repair - Multi-core VC2015 2.0
[10/06 07:52:28] HIGH MessageId Filter: Disabled
[10/06 07:52:28] HIGH FileTypeId Version: 3.00
[10/06 08:09:18] DEBUG Checking Autodownload: alt.binaries.teevee
[10/06 08:09:20] ERROR WorkerThread Died: DbWorker

Version 6.73 64 bit running on Vista.

The storage.db3 file for the group is 18.6 gig so I'd prefer to not try to download the headers again.
Provider is giganews.
Machine has 8 gigs of ram with over 3.5 gigs free, so it seems available memory is not an issue.
Illuminated
Occasional Contributor
Occasional Contributor
 
Posts: 20
Joined: Fri Nov 28, 2003 2:51 am

Re: 6.73 Crashes on show posts

Postby Quade » Fri Oct 06, 2017 10:23 am

What's your "display age" set to? I'd set it to "10" then try a "Show Posts" and see if it still crashes.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42403
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.73 Crashes on show posts

Postby Illuminated » Sat Oct 07, 2017 7:11 am

Quade wrote:What's your "display age" set to? I'd set it to "10" then try a "Show Posts" and see if it still crashes.


I had no limit on the display age. I set it to 10 and the posts loaded in seconds (< 5). I then did a lot of trial and error to find that all the way up to 249 days, the posts load in about the same amount of time (5-10 seconds). As soon as I go to 250, the progress bar is small and moves left to right repeatedly. Eventually it starts filling left to right as it normally does, gets to the right side after about a minute but then never gets past that (waited 10 minutes now). I expect if I wait long enough, the app will crash. Process Explorer shows the working set at 2.4 gb but it is not growing, not using any CPU, and not doing any I/O. Newsbin just appears to be stuck, for lack of a better explanation.

It appears there is something bad in the post data after 249 days. Is my only option to purge past 249 and attempt to reload those older headers using techniques detailed in other posts in this forum?
Illuminated
Occasional Contributor
Occasional Contributor
 
Posts: 20
Joined: Fri Nov 28, 2003 2:51 am

Re: 6.73 Crashes on show posts

Postby Quade » Sat Oct 07, 2017 8:19 pm

The groups were under attack around last Christmas so you might be running those attack posts. If that's the case re-downloading will just re-download the garbage again.

I'm not sure what to tell you. It's possible to delete a months worth of headers from the DB but the process is manual. If you're interested I could try to come up with a method for you.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42403
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.73 Crashes on show posts

Postby Illuminated » Mon Oct 09, 2017 6:53 am

If you can tell me what the database is and what client tool to use to connect to it, I can probably figure out the rest myself, assuming it's a SQL DB. No need for you to spend a bunch of time on this.

Thanks.
Illuminated
Occasional Contributor
Occasional Contributor
 
Posts: 20
Joined: Fri Nov 28, 2003 2:51 am

Re: 6.73 Crashes on show posts

Postby Quade » Mon Oct 09, 2017 8:53 am

In the data folder, in Spool_V6 each group has a folder. In the folder is a file called "Storage.db3". It's an Sqlite database.

The tables you'd probably want to trim are Compact_V4 and "CleanSubjects_V4".

There are many tools to edit Sqlite DB's.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42403
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.73 Crashes on show posts

Postby dexter » Mon Oct 09, 2017 9:51 am

Also, the database utility, sqlite3.exe, is distributed with Newsbin and should be sitting in the folder where the Newsbin executables are. By default it would be C:\Program Files\Newsbin. It is SQL-like but some commands are different. For example instead of Desc <tablename>, it's .schema <tablename>. The actual query statements are SQL

Summary of common commands are here https://www.sitepoint.com/getting-start ... -commands/
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9268
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest