Headers with no extension

Technical support and discussion of Newsbin Version 6 series.

Headers with no extension

Postby jamesio » Mon Feb 05, 2018 10:53 am

With the last few versions of Newsbin, I've been having my headers downloads go into the import directory and not have any ".gz" or ".txt" extension on them. I have to use a tool to bulk rename them with .txt and then they process.

Has anyone else had this? It happens every single time headers download.
jamesio
Occasional Contributor
Occasional Contributor
 
Posts: 39
Joined: Sun Jul 13, 2003 11:34 am

Registered Newsbin User since: 04/26/03

Re: Headers with no extension

Postby Quade » Mon Feb 05, 2018 11:53 am

It means the download is failing. They only get renamed when the download completes properly.

You probably need to check the logs for errors.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43229
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Headers with no extension

Postby jamesio » Mon Feb 05, 2018 12:10 pm

It seems that Sunnyusenet and Tweaknews are showing "Bad Compressed Header Format" in the logs.

Know if anything changed with them?
jamesio
Occasional Contributor
Occasional Contributor
 
Posts: 39
Joined: Sun Jul 13, 2003 11:34 am

Registered Newsbin User since: 04/26/03

Re: Headers with no extension

Postby Quade » Mon Feb 05, 2018 12:37 pm

In the server advanced options, I'd try disabling "XFeatures".

Honestly that error is misleading in RC4. It really means the connection failed. I haven't tracked down why it's showing the bad compression error.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43229
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Headers with no extension

Postby jamesio » Mon Feb 05, 2018 12:56 pm

I turned off xfeatures and still get the same thing on Tweaknews and Sunnyusenet. I don't get it on Supernews.
jamesio
Occasional Contributor
Occasional Contributor
 
Posts: 39
Joined: Sun Jul 13, 2003 11:34 am

Registered Newsbin User since: 04/26/03

Re: Headers with no extension

Postby Quade » Mon Feb 05, 2018 3:01 pm

Well, it sounds like the servers are disconnecting in the midst of the header download. Are you doing large header downloads or smaller ones?

You know you almost never need to download headers from multiple servers. I recommend picking the best server and only downloading headers from it.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43229
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 5 guests