Unable to Update/Insert NZB/Data record

Technical support and discussion of Newsbin Version 6 series.

Unable to Update/Insert NZB/Data record

Postby Murg » Tue Jul 03, 2018 6:18 pm

I just upgraded to 6.80 and am getting some headers not loading into the database with one of two errors:
    ERROR Unable to Update NZB Data Record
    ERROR Unable to Insert Data Record
Firstly, what's going on?

Secondly, how do I revert back to 6.73?
Murg
Active Participant
Active Participant
 
Posts: 71
Joined: Sat Jan 08, 2005 8:58 pm

Registered Newsbin User since: 01/05/05

Re: Unable to Update/Insert NZB/Data record

Postby Quade » Wed Jul 04, 2018 2:27 pm

1 - Probably a corrupt header database for that group. I'd probably wipe the group and re-download headers for it.

2 - Install and run it.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43228
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Unable to Update/Insert NZB/Data record

Postby Murg » Wed Jul 04, 2018 6:29 pm

I have over 10 years of headers in the groups affected, don't really want to re-download them.

Is there a way to repair the database?

I reinstalled 6.73. Now I'm getting these errors in 6.73, where I've haven't seen them before. Did 6.80 do something to the database?
Murg
Active Participant
Active Participant
 
Posts: 71
Joined: Sat Jan 08, 2005 8:58 pm

Registered Newsbin User since: 01/05/05

Re: Unable to Update/Insert NZB/Data record

Postby Quade » Wed Jul 04, 2018 9:01 pm

They're typically unrepairable. You can sometimes dump them out and re-create them. You can google for methods to dump and recreate Sqlite databases.

Unless many files are doing it, you might just ignore the error too. If it's not a huge group, it might be easier just to re-download the headers.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43228
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Unable to Update/Insert NZB/Data record

Postby Murg » Thu Jul 05, 2018 6:55 pm

Ok. I made a back up before I installed 6.80, so I'll restore that.

Unfortunately, the groups are large, and the headers with the problem are the ones I want. The spam, of course, is not having any problems.
Murg
Active Participant
Active Participant
 
Posts: 71
Joined: Sat Jan 08, 2005 8:58 pm

Registered Newsbin User since: 01/05/05


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests