6.80 — automatically loaded .nzbs moved to wrong folder(s)?

Technical support and discussion of Newsbin Version 6 series.

6.80 — automatically loaded .nzbs moved to wrong folder(s)?

Postby Moerges » Sun Jul 15, 2018 4:26 am

Hello there,

I have a minor issue with where .nzbs are moved that have been automatically loaded from a watched folder. I would be thankful if one of you fine folks could shed some light on this, or look into it if deemed necessary.

While I have been using Newsbin for quite a long time, I only finally moved to version 6 yesterday. Previously, I stuck with 5.59, because it was running well and I did not see the necessity to update, despite a few inconveniences; now, after building a new computer (which runs a 64-bit Windows 10 Pro, in case this is important), I decided to take version 6 for a spin—and I am glad I did, as there are several larger and smaller improvements that make it more streamlined for me to use.

However, there is one oddity in its behaviour for which I have not found any documentation and hence think it might be unintentional.

In version 5.59, with my watched folder set to G:\NewsBin temp\#NZBs, Newsbin moved the loaded .nzbs into an automatically-created subfolder called Loaded (so G:\NewsBin temp\#NZBs\Loaded). This is also the behaviour I have found described in the Newsbin documentation, for example here: https://help.newsbin.com/index.php/V600-Options-NZB_Files (I realise this is for an older version, but I have not been able to locate any updated information on this.)

Now, in version 6.80 build 5058, with my watched folder again set to G:\NewsBin temp\#NZBs, Newsbin moves the loaded .nzbs to C:\Users\Moerges\AppData\Local\Newsbin\Nzbs AND to C:\Users\Moerges\AppData\Local\Newsbin\Nzbs\Nzbs (to emphasise: I end up with two copies of the loaded .nzbs, one in the parent "Nzbs" folder, and one in a subfolder also called "Nzbs").

There is no "NZB Loading Filter" in place.

This is clearly not a significant problem and might be ultimately caused by a setting on my end, but on the chance that someone here knows what is going on, I thought I'd turn to this forum for help anyway.

Thank you in advance for any support you can offer.

Moerges

P.S.: In future versions, might it be worthwhile to allow the user to specify to which folder an auto-loaded .nzb file should be moved?
Moerges
n00b
n00b
 
Posts: 4
Joined: Sun Jul 15, 2018 3:25 am

Registered Newsbin User since: 01/29/10

Re: 6.80 — automatically loaded .nzbs moved to wrong folder(

Postby Quade » Sun Jul 15, 2018 10:22 am

My thoughts on this are that once you hand the NZB to Newsbin, what it does with them isn't really a user issue. Because you can always copy them to the autoload folders and keep your own copy of the NZB.

The technical reason it pre-copies all to the NZB's folder is because it's the only folder that newsbin KNOWs it has read/write access too. All NZB's go there including NZB's from Sonarr and other automated NZB Dowloaders.

I can consider a "copy to" folder. You could write a post-unrar script to copy the NZB's out of the NZB's folder too.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43314
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.80 — automatically loaded .nzbs moved to wrong folder(

Postby Moerges » Sun Jul 15, 2018 4:18 pm

Thank you for your reply, Quade. Makes sense why Newsbin handles .nzbs this way now, especially with the more restrictive nature of modern operating systems where read and write access is concerned.

I was merely surprised to see the behaviour deviate from what I was used to from 5.59 and thought there might be something wrong on my end, especially since I found it odd to see the .nzbs duplicated in the data folder. If this is intended, I have no issue with it, though.

Thank you for the idea of the post-unrar script, too.
Moerges
n00b
n00b
 
Posts: 4
Joined: Sun Jul 15, 2018 3:25 am

Registered Newsbin User since: 01/29/10

Re: 6.80 — automatically loaded .nzbs moved to wrong folder(

Postby Quade » Mon Jul 16, 2018 12:21 am

I was merely surprised to see the behaviour deviate from what I was used to from 5.59 and thought there might be something wrong on my end, especially since I found it odd to see the .nzbs duplicated in the data folder. If this is intended, I have no issue with it, though.


It's common for people to get used to a "feature" which was never a feature and to get thrown off when behavior changes.

I'm a bit surprised by this because more people complained about the NZB's not getting cleaned out after download than this "NZB's not moving to loaded" thing.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43314
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.80 — automatically loaded .nzbs moved to wrong folder(

Postby Moerges » Mon Jul 16, 2018 12:53 am

People certainly are creatures of habit—me firmly included. I had got so used to the "watch folder -> Loaded subfolder" routine after running a version 5 Newsbin for more than eight years that I thought something might be afoot when I saw it behave differently on version 6.

I'd never minded doing some manual tidying up once in a while—as in: cleaning out the Loaded folder—, nor do I normally have any use for the .nzbs once they've been loaded. So both solutions work perfectly fine for me, and as you said, someone who regularly needs to have the .nzbs saved can always do so via a simple script.

Thanks again for your time, Quade, and this excellent programme.
Moerges
n00b
n00b
 
Posts: 4
Joined: Sun Jul 15, 2018 3:25 am

Registered Newsbin User since: 01/29/10


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 10 guests