error in handling some NZB files?

Technical support and discussion of Newsbin Version 6 series.

error in handling some NZB files?

Postby shawn » Sat Mar 09, 2019 6:42 pm

I had seen this message about NZB files being corrupt off and on and hadn't bothered to look deeper into it. It seems like it's a problem with the Newsbin handles certain characters. I used Easynews to create the NZB file so I think it's probably okay. The problem seems to be with the posters name causing NZB to see it as corrupt. Here's the top lines from the NZB file:

<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE nzb PUBLIC "-//newzBin//DTD NZB 0.9//EN" "http://www.newzbin.com/DTD/nzb/nzb-0.9.dtd">
<nzb xmlns="http://www.newzbin.com/DTD/2003/nzb">
<file poster="Cách t? phuong &ETH;ông@m?t noi nào dó.tk (TF)" date="1552166866" subject="The Elite Team Presents www.EliteNZB.net, Powered by 4UX.NL, Only The Best 4 You!!!! [04/34] - &#34;Jinsi_12288_AtAIvBw998.part03.rar&#34; yEnc (01/60)">
<groups>


I selected a long list of files on Easynews web interface and if I include that file I get the corrupt NZB warning. Leave that file out and the NZB loads fine. Select just that one file and create a NZB file and I'll get the corrupt NZB warning so it seems like there is something in that header that Newsbin is choking on. Now it's possible that Easynews is choking on something and creating a bad NZB file but looking it over I don't see any obvious errors.

So I turn to Quade and ask should Newsbin be able to handle that header with the special characters? Do you see any errors in that bit?

Thanks for any help.
shawn
Seasoned User
Seasoned User
 
Posts: 202
Joined: Wed May 22, 2002 7:56 pm

Registered Newsbin User since: 04/02/03

Re: error in handling some NZB files?

Postby itimpi » Sat Mar 09, 2019 6:45 pm

I am reasonably certain the the XML standard says any non-ASCII characters need to be escaped. If so that would be an illegal NZB file.
The Newsbin Online documentation
The Usenettools for tutorials, useful information and links
User avatar
itimpi
Elite NewsBin User
Elite NewsBin User
 
Posts: 12591
Joined: Sat Mar 16, 2002 7:11 am
Location: UK

Registered Newsbin User since: 03/28/03

Re: error in handling some NZB files?

Postby shawn » Sat Mar 09, 2019 7:54 pm

Yes, after more tests it looks like the ampersand in that poster name is causing the issue. I passed the issue off to Easynews technical support so hopefully they will fix it.

Thanks for your help.
shawn
Seasoned User
Seasoned User
 
Posts: 202
Joined: Wed May 22, 2002 7:56 pm

Registered Newsbin User since: 04/02/03

Re: error in handling some NZB files?

Postby itimpi » Sun Mar 10, 2019 5:33 pm

Actually I would think that part IS legal. In XML you escape characters with sequences that start with & and finish with ; What is NOT allowed in the strict XML standard is accented characters - they are meant to be escaped although sometimes the checking for this is lax.
The Newsbin Online documentation
The Usenettools for tutorials, useful information and links
User avatar
itimpi
Elite NewsBin User
Elite NewsBin User
 
Posts: 12591
Joined: Sat Mar 16, 2002 7:11 am
Location: UK

Registered Newsbin User since: 03/28/03


Return to V6 Technical Support

Who is online

Users browsing this forum: Google [Bot], pjbrumby and 3 guests