6.81 Header download Error

Technical support and discussion of Newsbin Version 6 series.

6.81 Header download Error

Postby Teddy » Wed Jun 19, 2019 6:12 pm

Hello,
Since yesterday I can no longer download new headers, after a short time I get this error message and:
[06/19 22:48:41] ERROR BR: Read Failure: 15442 to read 0 Actual Read Code: 18446744071562145803
[06/19 22:48:41] ERROR BR: Read Failure - Would Block
[06/19 22:48:41] ERROR NEWS SERVER ERROR: Newshosting NNTPServer: zero bytes read from socket
the first 100000-200000 headers go fast then the error message comes up
another download works
Newshosting means it is the NewsBin
Greetings Teddy
User avatar
Teddy
Occasional Contributor
Occasional Contributor
 
Posts: 33
Joined: Fri May 11, 2012 1:42 pm

Registered Newsbin User since: 05/10/12

Re: 6.81 Header download Error

Postby Quade » Thu Jun 20, 2019 5:58 am

Since neither Newsbin nor Newshosting changed, I suspect a firewall blocking the downloads. One thing you could try would be to disabled XFeatures in the server "Really Advanced" options and see if it works.

Are you using SSL?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43605
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.81 Header download Error

Postby Teddy » Thu Jun 20, 2019 6:53 am

Hello,
It occurred suddenly, I did not change any settings or updats.
That's why I can not explain it to myself.
XFeatures is disabled and I've been using SSL and SSl V2 Europe forever.
Problem is with VPN and without.
It always comes the same error message.

update: I played an image from last week when everything was still running, the same problem.
I also believe that the problem is with Newshosting.

sorry my English is not so good
Greetings Teddy
User avatar
Teddy
Occasional Contributor
Occasional Contributor
 
Posts: 33
Joined: Fri May 11, 2012 1:42 pm

Registered Newsbin User since: 05/10/12

Re: 6.81 Header download Error

Postby Quade » Thu Jun 20, 2019 12:38 pm

If you want to send me a private message with the group name I can try it here. Some servers will error when you've downloaded X headers. Then Newsbin should retry and pull the test. This error might be SSL related too so, you could try disabling SSL and see if the header download works.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43605
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.81 Header download Error

Postby Teddy » Thu Jun 20, 2019 1:24 pm

XHeader is disabled with me. I've also disabled SSL and SSl V2, also tried different ports and server addresses, always the same error message.
It happens at all big "alt.binaries." Groups.
First it loads the headers quickly down(100000-200000Header) then nothing works and after some time the error message comes.
Greetings Teddy
User avatar
Teddy
Occasional Contributor
Occasional Contributor
 
Posts: 33
Joined: Fri May 11, 2012 1:42 pm

Registered Newsbin User since: 05/10/12

Re: 6.81 Header download Error

Postby Teddy » Thu Jun 20, 2019 5:52 pm

Hello Quad,
Thanks for your effort, case is done.
I've just tested another news server with the same settings, everything went fine.
I already thought that it is up to Newshosting, have it again written to the support, sometimes curious what they say now.
For years no problems.
They have certainly changed something to the server and the support knows nothing, was years ago ever.

update: I found in this folder c: \ Users \ xxxxx \ AppData \ Local \ Newsbin \ Import \
some of these files= alt.binaries.mom-posting-015107003476-015107103476
The date of the files only refers to the current errors
Greetings Teddy
User avatar
Teddy
Occasional Contributor
Occasional Contributor
 
Posts: 33
Joined: Fri May 11, 2012 1:42 pm

Registered Newsbin User since: 05/10/12

Re: 6.81 Header download Error

Postby Teddy » Sun Oct 06, 2019 10:36 am

Hello Quade,
so I still have the problem only with the header download. File download ok.I have already quit Newshosting and tried others. Now I am with Eweka, I have at least full speed when it runs. Whether with VPN or without, whether with SSL or without always the same error, XFeature is switched off. Which is strange, it happened with all news servers, so I think that it is up to Newsbin. Hope you can help me. This is annoying for over 3 months. These error messages always appear..
[10/06 15:13:51] ERROR BR: Read Failure: 872 to read 0 Actual Read Code: 18446744071562145803
[10/06 15:13:51] ERROR BR: Read Failure - Would Block
[10/06 15:13:51] ERROR Downloader: SocketException NEWS SERVER ERROR: Eweka NNTPServer: zero bytes read from socket Eweka
[10/06 15:17:04] ERROR BR: Read Failure: 6183 to read 0 Actual Read Code: 18446744071562145803
[10/06 15:17:04] ERROR BR: Read Failure - Would Block
[10/06 15:17:04] ERROR Downloader: SocketException NEWS SERVER ERROR: Eweka NNTPServer: zero bytes read from socket Eweka
[10/06 15:19:27] ERROR BR: Read Failure: 12139 to read 0 Actual Read Code: 18446744071562145803
[10/06 15:19:27] ERROR BR: Read Failure - Would Block
[10/06 15:19:27] ERROR Downloader: SocketException NEWS SERVER ERROR: Eweka NNTPServer: zero bytes read from socket Eweka

Have Newsbin 6.82B9 installed
Greetings Teddy
User avatar
Teddy
Occasional Contributor
Occasional Contributor
 
Posts: 33
Joined: Fri May 11, 2012 1:42 pm

Registered Newsbin User since: 05/10/12

Re: 6.81 Header download Error

Postby Quade » Sun Oct 06, 2019 11:40 am

It's not unusual to get connection errors from time to time. If your header downloads eventually work then I'd just ignore this error. It's not unusual for instance for a server to disconnect after delivering X bytes of data in order for them to account for the data more easily. I know for sure that Giganews will disconnect connections after some number of bytes transferred. I'm not clear on what all servers that do it. Specifically for Giganews I had to make a change to how errors are handled because they return a 400 error when they should be returning a 500 error. It's hard to say whether that will work on other servers. I do believe Eweka has a similar issue. That being the case, it means the errors will be random.

I was just polishing up the next version. Probably hand it off to Dex today.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43605
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.81 Header download Error

Postby Teddy » Sun Oct 06, 2019 1:48 pm

Thanks, but what I do not understand, it worked for years and all of a sudden started in June.
Greetings Teddy
User avatar
Teddy
Occasional Contributor
Occasional Contributor
 
Posts: 33
Joined: Fri May 11, 2012 1:42 pm

Registered Newsbin User since: 05/10/12

Re: 6.81 Header download Error

Postby Teddy » Sun Oct 13, 2019 4:55 pm

hey Quad, so please help me,
I also tried Grabit. Since there was no error message at the header download, the download has also stopped constantly and the download took forever,
as Newsbin. Newsbin creates a file for every error message in a group in the Import folder.
here the path: c:\Users\Teddy\AppData\Local\Newsbin\Import\alt.binaries.bloaf-Eweka-009513108414-009513208414
At 8 Group Updats 57 files from 4 Groups totaled 1 GB. So 57 mistakes took 1 hour 20 minutes. the error files from the 4 groups had millions of headers.
If I do not delete them every time, my hard drive will soon be full. Always delete these files when I quit Newsbin.
At the beginning the header download starts with 61Mbit / s then it stops and lasts until it goes on.
Is not there a way to have these files automatically deleted ? What can I do now ?
At Newshosting I had always deleted the error-created fils
The same problem with a 3rd news server.
Errors have occurred since June without me changing anything

At Newshosting I had always deleted the error-created fils.
Greetings Teddy
User avatar
Teddy
Occasional Contributor
Occasional Contributor
 
Posts: 33
Joined: Fri May 11, 2012 1:42 pm

Registered Newsbin User since: 05/10/12

Re: 6.81 Header download Error

Postby Quade » Sun Oct 13, 2019 5:44 pm

Files in the data folder like that should get automatically deleted when they get 2-3 days old.

You're not re-downloading headers from that group every time you download headers are you? It seems like it gets 8-10 million posts a day which is a decent amount but not huge. If you're downloading headers fairly frequently there shouldn't be all that many to download each time. Sometimes people do a "Download all" time after time which is almost always the wrong way to download headers. I just want to make sure you're not doing that.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43605
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 6 guests

cron