Trouble downloading headers

Technical support and discussion of Newsbin Version 6 series.

Trouble downloading headers

Postby GusForsman » Wed Oct 16, 2019 6:23 pm

Hi
I'm having trouble getting new headers from a newsgroup on my server. the error I get is:

[10/16 17:20:22] ERROR Downloader: Command Exception NEWS SERVER ERROR: NewsGroupDirect Illegal Group state Record ID's invalid: alt.binaries.multimedia.anime.highspeed NewsGroupDirect

I don't know if this is from the server or Newsbin pro 64. I have the newsgroup provider looking into it, but I thought I'd ask here also. I'm using version : 6.82B8: 00 F8 2C 00 8F 80 .
Other groups have no problem, just this one. Also, the bodies are on the server as I have downloaded some using an NZB service. Any help would be appreciated.
Gus
GusForsman
n00b
n00b
 
Posts: 5
Joined: Thu Mar 15, 2018 2:31 am

Re: Trouble downloading headers

Postby Quade » Wed Oct 16, 2019 9:45 pm

Newsbin is telling you the error but it's triggered from data from the server. . Typically it means and empty group or a group where the min count >= max count.

Code: Select all
[10/16 20:50:09]
[10/16 20:50:09]  DEBUG XOVER Numbers: alt.binaries.multimedia.anime.highspeed Min: 523100497 Max: 523200497 UNS
[10/16 20:50:09]  DEBUG UNS alt.binaries.multimedia.anime.highspeed XOVER: alt.binaries.multimedia.anime.highspeed 523100497:523200497
[10/16 20:50:12]  DEBUG XOVER Numbers: alt.binaries.multimedia.anime.highspeed Min: 523200497 Max: 523300497 UNS
[10/16 20:50:12]  DEBUG UNS alt.binaries.multimedia.anime.highspeed XOVER: alt.binaries.multimedia.anime.highspeed 523200497:523300497
[10/16 20:50:14]  DEBUG XOVER Numbers: alt.binaries.multimedia.anime.highspeed Min: 523300497 Max: 523400497 UNS
[10/16 20:50:14]  DEBUG UNS alt.binaries.multimedia.anime.highspeed XOVER: alt.binaries.multimedia.anime.highspeed 523300497:523400497
[10/16 20:50:17]  DEBUG XOVER Numbers: alt.binaries.multimedia.anime.highspeed Min: 523400497 Max: 523401037 UNS


This is what it looks like when I do this to Usenetserver. You could turn on "Show Server Commands" in the network option in Newsbin, they try again and see what Newsbin says to the server. You might need to restart Newsbin for it to engage.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43871
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Trouble downloading headers

Postby GusForsman » Thu Oct 17, 2019 3:17 am

This is what I get after turning that on. I did this twice and the only thing that changed is the time.

[10/17 02:18:50] ALWAYS NewsGroupDirect GROUP alt.binaries.multimedia.anime.highspeed | 211 -398177991 398177991 0 alt.binaries.multimedia.anime.highspeed
[10/17 02:18:50] ERROR Downloader: Command Exception NEWS SERVER ERROR: NewsGroupDirect Illegal Group state Record ID's invalid: alt.binaries.multimedia.anime.highspeed NewsGroupDirect

Gus
GusForsman
n00b
n00b
 
Posts: 5
Joined: Thu Mar 15, 2018 2:31 am

Re: Trouble downloading headers

Postby Quade » Thu Oct 17, 2019 11:11 pm

Looks like the server is reporting that the group is empty. I'd guess it's a bug in the group data. If you have another server, you might want to just download headers from this other server.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43871
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Trouble downloading headers

Postby GusForsman » Fri Oct 18, 2019 12:06 pm

I don't have another server. I passed along your comment to the tech at my server, maybe that will help. Is there anything else I could try?
Gus
GusForsman
n00b
n00b
 
Posts: 5
Joined: Thu Mar 15, 2018 2:31 am

Re: Trouble downloading headers

Postby Quade » Sat Oct 19, 2019 1:40 am

Not as far as I know. If you only have one server then you're at their mercy. Is this the only group giving you these symptoms? That looks like a pretty active group on my servers.

NewsGroupDirect GROUP alt.binaries.multimedia.anime.highspeed | 211 -398177991 398177991 0 alt.binaries.multimedia.anime.highspeed


This is the line you should show them. Newsbin say:
GROUP alt.binaries.multimedia.anime.highspeed


and the server says back:

211 -398177991 398177991 0 alt.binaries.multimedia.anime.highspeed


I don't know if that leading dash is an artifact of logging or actually in the response data.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43871
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 10 guests

cron