Corrupt DB: Nzbs

Technical support and discussion of Newsbin Version 6 series.

Corrupt DB: Nzbs

Postby gertjans » Wed Apr 22, 2020 6:37 am

After loading headers today, all storage for the downloaded groups is gone (in the spool_v6 folder). I am meant to believe the groups have no items, which is clearly incorrect.

When I try to load an nzb file that still worked yesterday, I now get the error:
[04/22 11:29:07] ERROR Insert Failed: Shouldn't be possible: corrupt DB: Nzbs

What to do?

I am running Newsbin Pro 6.82 - Build: 5142

Thanks,
Gert-Jan
gertjans
Occasional Contributor
Occasional Contributor
 
Posts: 10
Joined: Wed Nov 26, 2008 4:26 pm

Registered Newsbin User since: 04/02/03

Re: Corrupt DB: Nzbs

Postby gertjans » Wed Apr 22, 2020 10:58 am

After trying many different things, I managed to fix it when I changed the following part in the .ini from

DataPath=A:\NBPro\headers

to

DataPath=G:\NBPro\headers

I have no idea why that would make any difference. The only thing I can imagine is some very weird corruption on my drive A, even though there is no problem in using drive A for storing the downloaded messages.
gertjans
Occasional Contributor
Occasional Contributor
 
Posts: 10
Joined: Wed Nov 26, 2008 4:26 pm

Registered Newsbin User since: 04/02/03

Re: Corrupt DB: Nzbs

Postby Quade » Wed Apr 22, 2020 12:16 pm

Traditionally "A:\" is dedicated to what were floppy drives. I'd never use a hard drive letter of "A:" because there are certain assumptions built into that letter because of historical reasons. I'm not clear how it would ever get set to A: but PC's are all different.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43776
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 10 guests