High I/O from NB Pro with no downloads or group updates

Technical support and discussion of Newsbin Version 6 series.

High I/O from NB Pro with no downloads or group updates

Postby meclo » Wed Aug 04, 2021 12:24 pm

Hi,

Lately I've noticed that NB Pro will consume tons of I/O on my PC even though there are no header or file downloads going on. My disk is really noisy (cheap case) so I always know when it's spinning, and I've run resource monitor from task manager to determine that NB Pro is doing tons of both reads and writes.

Why would that be? I've even left it running overnight, and the next morning the hard drive is still chugging away.

I tried updating to 6.82 but that didn't resolve the issue. I don't usually download headers, though I did last week, and that's when I noticed the issue starting. I've deleted those groups from my group list though, thinking it was reading the spool info, but that didn't help. I even deleted the spool folder for the headers I downloaded but it's still pounding the disk.

Any ideas?

Thanks!
meclo
Occasional Contributor
Occasional Contributor
 
Posts: 21
Joined: Thu Feb 09, 2006 11:39 pm

Re: High I/O from NB Pro with no downloads or group updates

Postby Quade » Wed Aug 04, 2021 3:12 pm

Down where is shows "Cache: X/Y (Z)" What's Z? Until Z = 0, Newsbin is importing headers into the header database. My guess is that's your IO.

Some groups cause exorbitant amounts of disk IO. Typically it's from groups that are no longer productive for posts but only have obscured postings in them. You might find it's time to prune out some of the old mainstays because there's nothing useful posted there anymore.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44365
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: High I/O from NB Pro with no downloads or group updates

Postby meclo » Wed Aug 04, 2021 4:50 pm

Quade wrote:Down where is shows "Cache: X/Y (Z)" What's Z? Until Z = 0, Newsbin is importing headers into the header database. My guess is that's your IO.

Some groups cause exorbitant amounts of disk IO. Typically it's from groups that are no longer productive for posts but only have obscured postings in them. You might find it's time to prune out some of the old mainstays because there's nothing useful posted there anymore.


Thanks for the fast reply Quade! It says 400/400 (1813). How do I prune those groups? I've already deleted all of the groups from the Groups tab; I had about 15 in there before.
meclo
Occasional Contributor
Occasional Contributor
 
Posts: 21
Joined: Thu Feb 09, 2006 11:39 pm

Re: High I/O from NB Pro with no downloads or group updates

Postby meclo » Wed Aug 04, 2021 4:57 pm

Yeah, that's totally what it was. I went into my Newsbin\Import folder and saw a ton of text files for one of the groups I had downloaded headers for last week. I closed NB, nuked the contents of that folder and deleted the subfolder in the Spool folder as well; restarted NB Pro and it's not chugging I/O anymore, and that cache number is now 400/400 (0).

Thanks Quade!!
meclo
Occasional Contributor
Occasional Contributor
 
Posts: 21
Joined: Thu Feb 09, 2006 11:39 pm

Re: High I/O from NB Pro with no downloads or group updates

Postby Quade » Wed Aug 04, 2021 9:49 pm

That's a fix but it means you've thrown away all the headers you downloaded before Newsbin could integrate them.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44365
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to V6 Technical Support

Who is online

Users browsing this forum: Google [Bot] and 6 guests