Automatic downloading problems autopar

This is the place to help test and discuss Version 6 Beta releases.

Automatic downloading problems autopar

Postby oferlaor » Tue Sep 13, 2016 2:58 pm

Downloaded nzbs with 6.72 and had problems. The nzb file names had {{passwords}} and one didn't have a password.

The files seem to be downloading fine but the files don't all download to the same directories but to separate ones. If I move them all to a single directory and ran multipar it runs fine. I think there is a problem with the target directory.

I am also seeing problems with the decoding target for - automatically downloading files end up in the root directory of the unrar directory.

The settings are download folder:
C:\hd\finished\$(NZBFILE)\$(FILENAME)\

Nzb download directory:
c:\hd\finished\$(NZBFILE)\

Unrar folder:
v:\finished\finished\$(NZBFILE)\
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: Automatic downloading problems autopar

Postby oferlaor » Wed Sep 14, 2016 3:54 am

Not sure I was so clear (writing from my mobile phone...)

So, there are two problems here:
1. The internal download directory seems to be downloading a single NZB file in subdirectories instead of a flat directory structure (all the nzb files into the same directory), this may be causing problems with newsbin detecting multipar/autopar completion correctly and repairing files. I can do it manually if put all the files it downloaded into the same directory and then run multipar manually.

2. the unrar should be targeting the nzb (or file name) under the unrar dir. Instead, some files are now unraring to the root unrar directory.

I put my unrar file on top, the NZB watch folder and other filters don't have specific unrar or download dir settings (they are empty)

Ofer.
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: Automatic downloading problems autopar

Postby Quade » Wed Sep 14, 2016 9:16 am

I was puzzling over this. Didn't have an immediate suggestion. If I was trouble-shooting this, I'd pause, feed an nzb then look at the download path displayed. Then I'd let a PAR download and then check the unrar path in the properties for the set.

Do the files appear in a single line or are they in multiple lines?

Do you have any paths set in the NZB autoload item itself?

"$(FILENAME)" is always problematic. I'd probably not use it. The fact you have random download folders suggests that's part of your problem. I see no reason not to download all the files to the same flat folder unless each NZB uses the exactly same filenames for the source files. Then unrar to specific folders.

It kinda feels like it's using per group pathing maybe. You might be better off setting specific download and unrar paths in the NZB Autoload options.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42579
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Automatic downloading problems autopar

Postby oferlaor » Wed Sep 14, 2016 9:41 am

What I'm basically interested in getting is to separate the downloads into dedicated lines to prevent a mess in the download directory, but you are right, it isn't that important (mostly a chore to clean up, since i'm always left with some stuff in there).

The problem with the unrar seems to be related to automatically downloading from the groups. I use a filter to download from a group and it's supposed to unrar to a unique and identifiable directory... NZB name doesn't cut it in this case since there is no NZB involved...

What's the best way to achieve this?
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: Automatic downloading problems autopar

Postby oferlaor » Wed Sep 14, 2016 9:45 am

I see that the individual group filters have an unrar path of:
v:\finished\finished\$(FILENAME)\

I'll try and change it to:
v:\finished\finished\$(SUBJECT)\
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: Automatic downloading problems autopar

Postby Quade » Wed Sep 14, 2016 9:49 am

You've managed to confuse me. You first line is about using NZB files but now you're talking about automatic download with filtering.

So I'm not actually clear what you're doing. Are you or aren't you using NZB Files?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42579
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Automatic downloading problems autopar

Postby oferlaor » Wed Sep 14, 2016 10:34 am

that's why I had the second clarification message, I had managed to confuse myself.

This post is about two different issues, which I bundled together. The first was about downloading of NZB files that would not unpar because they were not using the same directory. To try and rectify that, I removed the $NZBNAME and $FILENAME from the download dir and I'm just using a fixed download dir now.

The second issue I had was with groups that are auto downloading headers with a download filter. Those groups started unraring to the root download dir (they are ignoring the $FILENAME). To try and rectify this, I've changed the main download dir and also the group properties to download using $SUBJECT instead of $FILENAME.

Hope this clarifies it.
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: Automatic downloading problems autopar

Postby oferlaor » Fri Sep 16, 2016 1:06 am

So the problem continues.

Although I changed the unrar path it seems like auto downloading groups stopped activating named variables in the unrar path.

Looks like a new 6.72 bug. It worked fine in 6.6
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: Automatic downloading problems autopar

Postby oferlaor » Fri Sep 30, 2016 3:40 pm

switched back to 6.62 and all is well there.

Any ideas?
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: Google [Bot] and 5 guests