auto unrar

This is the place to help test and discuss Version 6 Beta releases.

auto unrar

Postby oferlaor » Tue Dec 06, 2016 2:54 am

since upgrading to 6.73b4 some NZBs are not automatically unraring for me.

automatic downloads (groups that are downloaded and filtered) seem to be unraring fine.

For NZBs, I have to right click the items and from the menu select UnRAR and then it starts working (but not in the background...).

This issue + the password issue (the fact that {{passwords}}) are not working, are pretty big issues with this version (which otherwise works much better than previous versions!).
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby Quade » Tue Dec 06, 2016 2:18 pm

So are the ones that don't work all passworded?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42317
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: auto unrar

Postby oferlaor » Tue Dec 06, 2016 3:22 pm

I'm less confident there is a problem here. It might be an auto PAR issue.

Checking again.
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby oferlaor » Wed Dec 07, 2016 4:41 pm

Things are a bit clearer now

NZBs without passwords that pass autopar do not get automatically unrar-ed.

automatically downloaded groups (via filters) work fine for me.

I have an open item in the download list that I can unpar and unrar using the right click menus, but for some reason did not unrar automatically.
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby Quade » Wed Dec 07, 2016 5:03 pm

What's the chance you disabled unraring in the group options for the groups these files exist in?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42317
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: auto unrar

Postby oferlaor » Wed Dec 07, 2016 5:07 pm

it's the opposite, the NZBs are not unraring. Groups seem to be unraring fine.
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby Quade » Wed Dec 07, 2016 10:43 pm

Group options can still apply to NZB Files.

I'm not really sure what to tell you at this point. I have no other reports of unrar issues with NZB's and I download some NZB's during the week too. That's why I was wondering if it was a password issue. You might want to look at the logging tab after an error. You know, if the NZB UnRAR path is set to an illegal or missing path, the unrar won't happen too.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42317
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: auto unrar

Postby oferlaor » Thu Dec 08, 2016 2:14 am

But in that case manual unraring (right click unrar) wouldn't work right either and it did...
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby oferlaor » Thu Dec 08, 2016 2:24 am

There was an error

Unrar error: files damaged, not enough rars, needs repair or incorrect password

Is it possible that the unrar from right click is more capable of bypassing errors or that auto unrar tried to run before auto unpar was done?
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby oferlaor » Sat Dec 10, 2016 7:45 am

OK, I found a pattern here.

Whenever there is damage and the autoPAR is trying to repair, it always fails. If I do it manually (run Multipar) it repairs it fine, but the automatic one always fails, so it never gets to the UnRAR part.

Note, I'm running this on Windows 2003 X86 (very similar to windowsXP), it might be one of the causes?

BTW, I'm also getting repeated failures with negotiating the SSL connection with UsenetBucket. Not sure if that has something to do with it.

Is it possible that there's a change to the autoPAR plugin that is causing this?
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby oferlaor » Fri Dec 23, 2016 9:45 am

So I think this is a quick par issue.

I see that multipar successfully recovers these files.

Something in the integration changed.

Is it perhaps my OS? I am running on win 2003 (like xp)?
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby dexter » Fri Dec 23, 2016 11:08 am

What security software are you running? The combination of SSL errors and unrar problems from within Newsbin could point to a software conflict. We've had odd reports from people running Kaspersky, Avast, Norton, and Malwarebytes. To test, you can temporarily disable the security software, reboot your machine (this step is important) and then see if the symptoms go away. If they do then you know you need to look into configuring your security software to ignore Newsbin.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9255
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: auto unrar

Postby oferlaor » Fri Dec 23, 2016 12:15 pm

The ssl errors come and go but I did have various issues with usenet bucket.

I will remove the antivirus but I doubt it is the cause. I haven't upgraded it since moving to 6.7 and it always worked before.

I think the root cause is the auto par not working properly on my system with 6.7
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby dexter » Fri Dec 23, 2016 12:58 pm

The newer version of Newsbin would look like new software to your security software. Could be you had it configured to ignore the older version but now the newer version it is messing with it. When odd things like this happen to one person and not 1000's at the same time, it means there is some local issue and usually it's a software conflict.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9255
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: auto unrar

Postby oferlaor » Fri Dec 23, 2016 1:19 pm

i've killed off the antivirus completely now.

I've also reviewed my server settings. Looks like I was using SSLv2 or some reason. I've turned off all the advanced features.

I'm going to first revert to 6.62 and see if its as stable as I remember it was and then, in a week or two, try again with 6.74 using the same settings.
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby oferlaor » Mon Feb 20, 2017 6:49 am

It's been a while, so after reverting back go 6.6X for a while (and having almost no problems in that department) I have upgraded again to 6.73RC2. I'm running on Windows 2003 (equivalent to Windows XP).

The problem is still there - I have some completed downloads that are stuck without being unrared. Note that not all items get stuck this way, things that automatically download appear to be working fine.

From what I can see, both items that I have stuck in out download folder were both passworded NZBs that were originally put there using the watch folder.

If I check, the files are all there and they may have been repaired (I can't tell if they were or not, but multipar runs fine on them).

At this point, if I right click and select unRAR, it does unrar them successfully. From what I can see in the logs, the autoPAR reports that the repair failed and the software doesn't continue on to the next step of unRARing. From what I can see either the AutoPAR stage does not work correctly or doesn't report that it's working correctly...

How can I help you guys diagnose this issue? It seems like it's been there for a while and I would hate to downgrade back down to 6.62, which works fine.
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby oferlaor » Mon Feb 20, 2017 2:54 pm

I'm going to try and take the par2repair from 6.62 and move it to 6.73 - let's see what happens...
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06

Re: auto unrar

Postby Quade » Mon Feb 20, 2017 3:44 pm

the autoPAR reports that the repair failed and the software doesn't continue on to the next step of unRARing.


This is the key and it's how it's designed to work. So the question is, why are the repairs failing. It's pretty low-level and whether the RAR's are password protect shouldn't matter.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42317
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: auto unrar

Postby oferlaor » Mon Feb 20, 2017 4:03 pm

How can I help you diagnose it?

I sure the OS has something to do with it since if this was commonplace everyone would have this problem.

It seems like an issue that has to do with par2repair.dll that was changed between 6.62 and 6.7x
oferlaor
Seasoned User
Seasoned User
 
Posts: 415
Joined: Sun Oct 08, 2006 11:02 am

Registered Newsbin User since: 04/21/06


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron