Version 6.80 Beta 7 Available...

This is the place to help test and discuss Version 6 Beta releases.

Version 6.80 Beta 7 Available...

Postby dexter » Wed Aug 16, 2017 6:55 pm

Beta 7 has a ton of changes and fixes. Mostly around PAR processing. It's alot to list here so best if you just go to the Newsbin Beta Page and click on the "Changes in this Version" tab. The download button is at the top of that page.

If you find any issues, please reply to this thread or use our Technical Support Contact Form.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9252
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby johnisme » Thu Aug 17, 2017 3:51 pm

Have no issues running the newest build,the only thing i see is when i click on help in settings i get this message-Windows can't find the file, and after that there's a list of Chinese symbols.
User avatar
johnisme
Active Participant
Active Participant
 
Posts: 77
Joined: Mon Sep 24, 2007 12:00 am

Registered Newsbin User since: 09/22/07

Re: Version 6.80 Beta 7 Available...

Postby dexter » Thu Aug 17, 2017 4:57 pm

Hmm, so it does. Thanks for pointing that out. Will be fixed in the next one.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9252
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby kirm » Thu Aug 17, 2017 10:00 pm

Just wanted to confirm that all my files are going into the proper folders paths again. Thanks guys
kirm
Seasoned User
Seasoned User
 
Posts: 196
Joined: Sun Aug 17, 2003 4:17 pm

Registered Newsbin User since: 05/15/03

Re: Version 6.80 Beta 7 Available...

Postby Mobius » Fri Aug 18, 2017 2:19 am

Pars do not get deleted after unrar. I checked settings and tried toggling it.
Mobius
Occasional Contributor
Occasional Contributor
 
Posts: 28
Joined: Mon Aug 10, 2009 8:27 pm

Registered Newsbin User since: 08/18/09

Re: Version 6.80 Beta 7 Available...

Postby stavros » Fri Aug 18, 2017 3:13 am

I'm seeing messages in the log every 20 seconds:

[08/18 06:53:15] DEBUG NZB File Load Checking
[08/18 06:53:35] DEBUG NZB File Load Checking
[08/18 06:53:55] DEBUG NZB File Load Checking
[08/18 06:54:15] DEBUG NZB File Load Checking
[08/18 06:54:36] DEBUG NZB File Load Checking
[08/18 06:54:56] DEBUG NZB File Load Checking

I don't have any NZB Watch folders defined.....

Should newsbin be doing any checking if no folders are defined?

regards
Stavros.
stavros
Occasional Contributor
Occasional Contributor
 
Posts: 45
Joined: Wed Dec 24, 2003 2:07 am

Registered Newsbin User since: 12/24/03

Re: Version 6.80 Beta 7 Available...

Postby Quade » Fri Aug 18, 2017 9:01 am

[08/18 06:54:15] DEBUG NZB File Load Checking


This just tells you the process looking for NZB load folders is checking. Some people are reporting the NZB file loading stops working so, this is a message to me to help trouble-shoot.

Pars do not get deleted after unrar. I checked settings and tried toggling it.


Is "Pause pars" unchecked in the Autopar options?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby Mobius » Sat Aug 19, 2017 2:53 am

Is "Pause pars" unchecked in the Autopar options?


It was unchecked. I checked it and now pars are getting deleted after unrar again. Thank you!
Last edited by Mobius on Sat Aug 19, 2017 12:41 pm, edited 1 time in total.
Mobius
Occasional Contributor
Occasional Contributor
 
Posts: 28
Joined: Mon Aug 10, 2009 8:27 pm

Registered Newsbin User since: 08/18/09

Re: Version 6.80 Beta 7 Available...

Postby JayPea » Sat Aug 19, 2017 3:11 am

After upgrading to the latest beta it looks like additional files (.nfo etc) are being collapsed into the set and need to be expanded to be viewed. Was this intentional or an oversight? I'd like to change my client back to how is was before, if possible, but I can't for the life of me remember where the option was set. I have a vague recollection of it being manually set in the .nbi file but if it's been stripped out then I'm lost.

If I need to revert back to the previous beta, please let me know.

Cheers.
JayPea
Active Participant
Active Participant
 
Posts: 72
Joined: Tue Dec 12, 2006 2:48 pm
Location: Wales

Registered Newsbin User since: 12/11/06

Re: Version 6.80 Beta 7 Available...

Postby stavros » Sat Aug 19, 2017 8:59 pm

Thanks Quade,

But as I don't have any NZB Watch folders defined, should newsbin be doing any checking if no folders are defined?

Is there any way to stop the NZB checking process from running, maybe via the .nbi file, if not having any watch folders defined isn't enough?

I have newsbin installed on a non-system hard drive and generaly leave newsbin (and the PC) running all the time, so is this NZB checking process keeping this drive from spinning down?

regards
Stavros.
stavros
Occasional Contributor
Occasional Contributor
 
Posts: 45
Joined: Wed Dec 24, 2003 2:07 am

Registered Newsbin User since: 12/24/03

Re: Version 6.80 Beta 7 Available...

Postby Quade » Sun Aug 20, 2017 11:21 am

But as I don't have any NZB Watch folders defined, should newsbin be doing any checking if no folders are defined?
Is there any way to stop the NZB checking process from running, maybe via the .nbi file, if not having any watch folders defined isn't enough?
I have newsbin installed on a non-system hard drive and generaly leave newsbin (and the PC) running all the time, so is this NZB checking process keeping this drive from spinning down?


- Are there any watch folders
- Log that check
- Nope no watch folders
- Do something else.

This is basically what it's doing. Keep in mind that Newsbin does a bunch of stuff on disk all the time and makes no effort to allow the drive to spin down. Checking for downloaded headers and cleaning out the data folder periodically are likely culprits to keeping the data folder drive spinning.

After upgrading to the latest beta it looks like additional files (.nfo etc) are being collapsed into the set and need to be expanded to be viewed. Was this intentional or an oversight? I'd like to change my client back to how is was before, if possible, but I can't for the life of me remember where the option was set. I have a vague recollection of it being manually set in the .nbi file but if it's been stripped out then I'm lost.


This is the way it works. Specifically it works this way so Ctrl-R can pull information from all of these files at once including the SRR and PAR files which often contain a copy of the NFO.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby stavros » Sun Aug 20, 2017 12:38 pm

OK, thanks for explanation Quade.
stavros
Occasional Contributor
Occasional Contributor
 
Posts: 45
Joined: Wed Dec 24, 2003 2:07 am

Registered Newsbin User since: 12/24/03

Re: Version 6.80 Beta 7 Available...

Postby alexon » Sun Aug 20, 2017 5:35 pm

Strange downloading process in beta7. First time watching this
For example: I download not compressed gallery (100-200 files). The download takes only a few seconds. Then the download finishes and the files, one by one, slowly begin to appear in the target folder with a speed of 2 files per second.
System (Win7 64bit Ult) and the download folder on different SSD, 64 Gb RAM, The CPU usage is minimal
In beta 6 the files usually appear in the downloads folder in sync with the downloading (and only in the case of a very large number of small files download ended before the files appeared in the download folder)
Was forced to return to beta 6.
Now everything is working quickly again.
Sorry for my bad English
alexon
n00b
n00b
 
Posts: 4
Joined: Mon Jul 22, 2013 6:30 am

Registered Newsbin User since: 08/25/12

Re: Version 6.80 Beta 7 Available...

Postby JanJonkman » Mon Aug 21, 2017 1:29 am

An other weird thing is that the spool directory is doubled in size in relation to V6

Jan
JanJonkman
Active Participant
Active Participant
 
Posts: 64
Joined: Tue Jan 17, 2012 12:35 pm

Registered Newsbin User since: 12/10/10

Re: Version 6.80 Beta 7 Available...

Postby JayPea » Mon Aug 21, 2017 2:56 am

Quade wrote:
This is the way it works. Specifically it works this way so Ctrl-R can pull information from all of these files at once including the SRR and PAR files which often contain a copy of the NFO.


I already downgraded back to 6.72 and restored my non-compacted view. Are you saying that the CombineMeta=0 command in the .nbi file will no longer work going forward? I'll try myself once a more stable release is available but what with the compacting and the painfully slow smaller file downloading I'm out for this current round of beta adventures.
JayPea
Active Participant
Active Participant
 
Posts: 72
Joined: Tue Dec 12, 2006 2:48 pm
Location: Wales

Registered Newsbin User since: 12/11/06

Re: Version 6.80 Beta 7 Available...

Postby grantboucher » Mon Aug 21, 2017 3:49 am

The "Delete RARs and PARS to the Recycle Bin setting" does not seem to be working. It's checked and yet the Recycle Bin is not filling up.

BTW Delete RARs and PARS on successful UnRAR is also checked. Should it not be?

Everything else seems to be working normally for me.
grantboucher
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Wed Aug 20, 2003 5:07 pm

Registered Newsbin User since: 04/10/03

Re: Version 6.80 Beta 7 Available...

Postby Quade » Mon Aug 21, 2017 1:33 pm

The "Delete RARs and PARS to the Recycle Bin setting" does not seem to be working. It's checked and yet the Recycle Bin is not filling up.


Looks like you're right. Wonder of recycle bin doesn't like long path support?

As for slow files into the files list, I'll test it. Not really noticing it here. It does unrar single-ton RAR files immediately.

"Combinemeta" is still in there. Should still be working. I'll have to see what it's doing. Certain obscured formats, the NFO files and the like aren't actually named "NFO" anymore
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby DaveXVI » Thu Aug 24, 2017 3:37 am

It looks like this release fixed the problem with the pars not going to the Wish List, so thanks for that.

But now my Files List isn't showing the files I download. I'm not talking about after a restart, I mean even during the session. Is there a switch for this that somehow got toggled? I just did a standard upgrade like I have for years, and never had to change anything about the Files List.
DaveXVI
Seasoned User
Seasoned User
 
Posts: 228
Joined: Sun Oct 16, 2005 4:47 pm

Registered Newsbin User since: 04/23/04

Re: Version 6.80 Beta 7 Available...

Postby Quade » Thu Aug 24, 2017 9:12 am

It looks like this release fixed the problem with the pars not going to the Wish List, so thanks for that.

But now my Files List isn't showing the files I download. I'm not talking about after a restart, I mean even during the session. Is there a switch for this that somehow got toggled? I just did a standard upgrade like I have for years, and never had to change anything about the Files List.


I suspect disabling autopar currently disables both "Ctrl-R" and "files to files list". The files are still ending up on disk but not added to the files list. I've been considering a fix. You might want to turn on autopar for now but disable unrar.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby Streetwolf » Thu Aug 24, 2017 6:37 pm

alexon wrote:Strange downloading process in beta7. First time watching this
For example: I download not compressed gallery (100-200 files). The download takes only a few seconds. Then the download finishes and the files, one by one, slowly begin to appear in the target folder with a speed of 2 files per second.
System (Win7 64bit Ult) and the download folder on different SSD, 64 Gb RAM, The CPU usage is minimal
In beta 6 the files usually appear in the downloads folder in sync with the downloading (and only in the case of a very large number of small files download ended before the files appeared in the download folder)
Was forced to return to beta 6.
Now everything is working quickly again.
Sorry for my bad English


I have the same problem. I was downloading about 2,000 picture ~200KB in size. On my 1Gbps connection it took really quick to download them. However, like the poster I am quoting, the files in the download list were still appearing about every 2 seconds even though my download folder had all the files in it. The speed indicator was zero during this time.
3770K 5Ghz|ASUS P8Z77-V DLX|Corsair 1050W PSU|Corsair H100iV2 CPU Cooler|Corsair 16GB RAM|Sapphire Nitro R9 390 8GB|DUAL ASUS PA249Q IPS 24" LCDs|Samsung SSD 830, 840 256GB|2TB Seagate|Windows 10 Pro x64|AMD 17.8.1|FIOS 1Gb
User avatar
Streetwolf
Seasoned User
Seasoned User
 
Posts: 814
Joined: Wed Feb 12, 2003 12:06 am
Location: Subnet 255.255.255.0

Registered Newsbin User since: 03/27/03

Re: Version 6.80 Beta 7 Available...

Postby BZee » Fri Aug 25, 2017 5:18 am

Streetwolf wrote:
alexon wrote:Strange downloading process in beta7. First time watching this
For example: I download not compressed gallery (100-200 files). The download takes only a few seconds. Then the download finishes and the files, one by one, slowly begin to appear in the target folder with a speed of 2 files per second.
System (Win7 64bit Ult) and the download folder on different SSD, 64 Gb RAM, The CPU usage is minimal
In beta 6 the files usually appear in the downloads folder in sync with the downloading (and only in the case of a very large number of small files download ended before the files appeared in the download folder)
Was forced to return to beta 6.
Now everything is working quickly again.
Sorry for my bad English


I have the same problem. I was downloading about 2,000 picture ~200KB in size. On my 1Gbps connection it took really quick to download them. However, like the poster I am quoting, the files in the download list were still appearing about every 2 seconds even though my download folder had all the files in it. The speed indicator was zero during this time.


I three. I first noticed the zero download speed but files appearing!
BZee
Seasoned User
Seasoned User
 
Posts: 429
Joined: Thu Sep 27, 2001 9:10 pm
Location: California

Registered Newsbin User since: 04/13/03

Re: Version 6.80 Beta 7 Available...

Postby Quade » Fri Aug 25, 2017 9:09 am

I have the same problem. I was downloading about 2,000 picture ~200KB in size. On my 1Gbps connection it took really quick to download them. However, like the poster I am quoting, the files in the download list were still appearing about every 2 seconds even though my download folder had all the files in it. The speed indicator was zero during this time.


I have to re-think it. As you point out, the download is fast but the files list update is slow. Basically the download is faster than the display update. That's because files list feed is coming from the thread that handles autopar so, if autopar is disabled or delayed because of repair, the files list update will stall. I moved it there for efficiency but I can see now that it causes that delay.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby EvanVanVan2 » Mon Aug 28, 2017 8:52 am

Most of my downloads are no longer being condensed into a single line item in the download list in B7. Does this have to do with NZB or is it something in Newzbin that has changed?

Thank you
EvanVanVan2
Active Participant
Active Participant
 
Posts: 60
Joined: Tue Nov 08, 2005 2:32 am

Registered Newsbin User since: 01/12/10

Re: Version 6.80 Beta 7 Available...

Postby Quade » Mon Aug 28, 2017 9:49 am

Email me a sample NZB and I'll be able to tell you. If it's one of those random subject postings (which are increasingly common) there won't be any grouping.

ts@newsbin.com
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby EvanVanVan2 » Mon Aug 28, 2017 10:24 am

Done, thank you. Yeah it could be that simple, at first I thought it was all downloads but just as I was writing that post I got one that did condense...
EvanVanVan2
Active Participant
Active Participant
 
Posts: 60
Joined: Tue Nov 08, 2005 2:32 am

Registered Newsbin User since: 01/12/10

Re: Version 6.80 Beta 7 Available...

Postby kirm » Tue Aug 29, 2017 2:36 pm

Tried to reply to a post in beta 7 and it failed, or I thought it failed. It actually did post but the reply remained stuck in the download descriptions: section, without clearing out. Tried to post a pic but couldn't get in here using the Img button.
kirm
Seasoned User
Seasoned User
 
Posts: 196
Joined: Sun Aug 17, 2003 4:17 pm

Registered Newsbin User since: 05/15/03

Re: Version 6.80 Beta 7 Available...

Postby Quade » Wed Aug 30, 2017 12:15 pm

Ok thanks. I have an action item to look at posting status.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby Quade » Wed Aug 30, 2017 8:39 pm

Most of my downloads are no longer being condensed into a single line item in the download list in B7. Does this have to do with NZB or is it something in Newzbin that has changed?


This NZB IS one of the random subject NZB's but it's not entirely clear why it's not compacting. I'm looking at it. Because the NZB itself adds the proper formatting to compact even if the underlying data is random. It has a random from field too so that might explain it.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby chiphead » Mon Sep 04, 2017 1:14 pm

In the download list, highlighted sort seems to be not hooked up. It updates the screen, but doesn't sort.

When nothing is selected, sort by column works.
User avatar
chiphead
Occasional Contributor
Occasional Contributor
 
Posts: 22
Joined: Wed Mar 08, 2006 11:17 am

Registered Newsbin User since: 03/08/06

Re: Version 6.80 Beta 7 Available...

Postby Quade » Mon Sep 04, 2017 10:01 pm

Ok thanks. I'll have to check it out.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42305
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 7 Available...

Postby alanstarr » Mon Sep 04, 2017 11:32 pm

chiphead wrote:In the download list, highlighted sort seems to be not hooked up. It updates the screen, but doesn't sort.

When nothing is selected, sort by column works.


Just came here to report the same problem!
alanstarr
Occasional Contributor
Occasional Contributor
 
Posts: 35
Joined: Sun Jan 23, 2005 2:49 pm
Location: Lawrence, MA

Registered Newsbin User since: 01/20/05

Re: Version 6.80 Beta 7 Available...

Postby Wildfire » Sun Sep 10, 2017 6:57 pm

Quade wrote:
It looks like this release fixed the problem with the pars not going to the Wish List, so thanks for that.

But now my Files List isn't showing the files I download. I'm not talking about after a restart, I mean even during the session. Is there a switch for this that somehow got toggled? I just did a standard upgrade like I have for years, and never had to change anything about the Files List.


I suspect disabling autopar currently disables both "Ctrl-R" and "files to files list". The files are still ending up on disk but not added to the files list. I've been considering a fix. You might want to turn on autopar for now but disable unrar.


I had the same issue, the Files List remained empty. Enabling AutoPAR (without enabling UnRAR) fixes it, but I don't want AutoPAR to be active. I handle the PAR process, where necessary, manually.

---

Also, the MOTD stopped showing up. It's enabled in the options, but it's just not showing up anymore. Previously, each time I started NewsBin Pro the MOTD would pop up. It doesn't anymore...
Wildfire
Active Participant
Active Participant
 
Posts: 73
Joined: Sun May 26, 2002 1:33 pm

Registered Newsbin User since: 04/12/03

Re: Version 6.80 Beta 7 Available...

Postby itimpi » Sun Sep 10, 2017 7:38 pm

Wildfire wrote:
Quade wrote:Also, the MOTD stopped showing up. It's enabled in the options, but it's just not showing up anymore. Previously, each time I started NewsBin Pro the MOTD would pop up. It doesn't anymore...
the MOTD is only meant to show when it changes - not every time you launch Newsbin.
The Newsbin Online documentation
The Usenettools for tutorials, useful information and links
User avatar
itimpi
Elite NewsBin User
Elite NewsBin User
 
Posts: 12538
Joined: Sat Mar 16, 2002 7:11 am
Location: UK

Registered Newsbin User since: 03/28/03

Re: Version 6.80 Beta 7 Available...

Postby Wildfire » Sun Sep 10, 2017 7:55 pm

itimpi wrote:
Wildfire wrote:
Quade wrote:Also, the MOTD stopped showing up. It's enabled in the options, but it's just not showing up anymore. Previously, each time I started NewsBin Pro the MOTD would pop up. It doesn't anymore...
the MOTD is only meant to show when it changes - not every time you launch Newsbin.


Then the function must have been buggy before - it showed each and every time I started NewsBin Pro. :P
Wildfire
Active Participant
Active Participant
 
Posts: 73
Joined: Sun May 26, 2002 1:33 pm

Registered Newsbin User since: 04/12/03

Re: Version 6.80 Beta 7 Available...

Postby dexter » Sun Sep 10, 2017 11:25 pm

It will show up every time if Newsbin is not registered properly. Likely you resubmitted your registration key since you last observed the issue. It is working as designed.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9252
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 3 guests