6.80B7&8 issue with Sonarr

This is the place to help test and discuss Version 6 Beta releases.

6.80B7&8 issue with Sonarr

Postby TotalHavoc » Tue Sep 19, 2017 9:32 am

I'm having issues with Sonarr and Newsbin playing nice together. The issue started after I upgraded to 6.80B7 last week. Right now Sonarr will send download requests but it never hears back from Newsbin about the status of the download and thus does not import the download. I'm getting the following error in Newsbin after about 10-20% of the file has been downloaded:

[09/19 06:07:45] ERROR SB - Failed to feed New NZB to Download list - Could be duplicate <something>

Any ideas?

EDIT: I just rolled back to B5, never loaded B6, and it is still doing it. This problem just started last week so I'm not sure what is going on. Sonarr has not updated their version in over a month.

EDIT2: I rolled back to 6.73 and everything is working. So it is something in the betas but why did it just start last week? It has been working fine since I went to B4 in June from 6.73
TotalHavoc
Occasional Contributor
Occasional Contributor
 
Posts: 23
Joined: Sun Feb 27, 2005 3:52 pm

Registered Newsbin User since: 08/22/03

Re: 6.80B7&8 issue with Sonarr

Postby Quade » Tue Sep 19, 2017 12:29 pm

Looking at this is on my list. I can't get anyone to look at the Sonarr logs and tell me if anything is listed there.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42396
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.80B7&8 issue with Sonarr

Postby TotalHavoc » Tue Sep 19, 2017 1:58 pm

This is all I'm seeing in the Sonarr log at the time I started testing early this morning:

17-9-19 05:55:57.2|Info|Sabnzbd|Adding report [<something>.US.S25E01.720p.WEB.x264-TBS] to the queue.
17-9-19 05:56:18.4|Info|DownloadService|Report sent to Newsbin. <something>.US.S25E01.720p.WEB.x264-TBS
17-9-19 05:56:19.0|Info|RssSyncService|RSS Sync Completed. Reports found: 602, Reports grabbed: 1

It never shows up in the activity list or anything.
TotalHavoc
Occasional Contributor
Occasional Contributor
 
Posts: 23
Joined: Sun Feb 27, 2005 3:52 pm

Registered Newsbin User since: 08/22/03

Re: 6.80B7&8 issue with Sonarr

Postby Quade » Tue Sep 19, 2017 9:26 pm

Ok fixed it. I need to do a bit more testing before the next beta is out.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42396
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.80B7&8 issue with Sonarr

Postby TotalHavoc » Wed Sep 20, 2017 8:58 am

Let me know if you need me to test anything.

Thanks!
TotalHavoc
Occasional Contributor
Occasional Contributor
 
Posts: 23
Joined: Sun Feb 27, 2005 3:52 pm

Registered Newsbin User since: 08/22/03

Re: 6.80B7&8 issue with Sonarr

Postby TotalHavoc » Sat Sep 23, 2017 12:33 pm

Problem still exists in B9:

Newsbin:
[09/23 11:26:28] ERROR SB - Failed to feed New NZB to Download list - Could be duplicate <something>.s01e04.webrip.nzb

Sonarr:
17-9-23 11:25:57.1|Info|NzbSearchService|Searching 4 indexers for [<something> : S01E04]
17-9-23 11:26:01.5|Info|DownloadDecisionMaker|Processing 6 releases
17-9-23 11:26:07.6|Info|Sabnzbd|Adding report [<something>.s01e04.webrip] to the queue.
17-9-23 11:26:28.7|Info|DownloadService|Report sent to Newsbin. <something>.s01e04.webrip
EOF

The file downloaded fine but it just sits in the completed folder.

EDIT: I opened the settings menu to check all my settings. Didn't change anything, saved out and now it appears to be working. I will do some more testing and let you know
TotalHavoc
Occasional Contributor
Occasional Contributor
 
Posts: 23
Joined: Sun Feb 27, 2005 3:52 pm

Registered Newsbin User since: 08/22/03

Re: 6.80B7&8 issue with Sonarr

Postby Quade » Sat Sep 23, 2017 10:37 pm

Since it's working I won't do anything. The unrar path can't be the same as file final path in Sonarr, they need to be distinct folders.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42396
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.80B7&8 issue with Sonarr

Postby TotalHavoc » Sun Sep 24, 2017 8:41 am

Well now it seems to be sporadic. It did not work on <something> or <something else> this morning. The paths are different. Newsbin unrars to d:\Sonarr and then Sonarr moves them to s:\TV Shows\<show>\<season>\<episode> when it is working.
TotalHavoc
Occasional Contributor
Occasional Contributor
 
Posts: 23
Joined: Sun Feb 27, 2005 3:52 pm

Registered Newsbin User since: 08/22/03

Re: 6.80B7&8 issue with Sonarr

Postby Quade » Sun Sep 24, 2017 10:19 am

The paths are different. Newsbin unrars to d:\Sonarr and then Sonarr moves them to s:\TV Shows\<show>\<season>\<episode> when it is working.


This is primarily how I tested it too. I tested 8-10 files and they consistently got moved. If you can determine some pattern I can look into it. The NZB's should be getting stored in the "<Data Folder>\NZB" folder in the data folder. If you can figure out what NZB's are problematic, you could email them to me to look at.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42396
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: Bing [Bot] and 6 guests