Version 6.80 Beta 11 Available...

This is the place to help test and discuss Version 6 Beta releases.

Version 6.80 Beta 11 Available...

Postby dexter » Sat Nov 04, 2017 9:08 am

More fixes in this version:

Summary:
  • Fixed issue with NZB pathing
  • Fixed issue where files that became complete in subsequent header downloads weren't getting fed in auto mode.
  • Fixed issue with 32 bit build, was not allowing access to the MOTD or the Search server.
  • Fixed issue where the Failed List would sometimes not show why the post failed in the Status column.
  • Implemented new hidden option to control how Newsbin handles unrar rar files within rar files.
    In the newsbin.nbi file, go to the [AutoRAR] section and set RecursiveUnRAR = 0 to disable. Default is enabled.
  • Fixed issue where changing Rename settings weren't taking effect for unrar functions until after a restart.
  • Fixed issue where some sets of pars didn't get deleted along with the RAR files.
  • Improvements to Sonarr integration
  • Added support for parsing and displaying rgss3a and rgss2a files in image viewer

    Known issue: Find history not being saved in Download List and Failed Files List
Download link is on the Newsbin Beta Page.

If you find any issues, please reply to this thread or use our Technical Support Contact Form.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9280
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby chimmyjim » Sun Nov 05, 2017 2:15 am

Hiya,

I'm having a couple of issues with this version that I also saw on B10.
- Download bypass filters does not seem to work reliably. The file will fail instantly, usually when the rar has an .exe's. The Spam setting on failing exe's does not change the behavior. This is very inconsistent, even with the same item. The nth try to download bypass filters the same item will suddenly work.
- Par's are failing on some posts. After downloading, Quickpar shows everything is correct. The error in Newsbin is "ERROR AutoPAR: PAR file might be Damaged, Unable to Add Parfile: ". When this happens, I am not able to unrar using Newsbin either. Using 7zip after downloading correctly extracts the file with no errors. There is no error or log message on unrar failure, it appears to be a completely silent failure.
- Removing an item that is currently downloading from the download list causes the program to hang for 10-45 seconds. This happens 100% of the time. It does not happen when the item is not currently downloading. I haven't been able to figure out any correlation on why there is a large difference in the hang time.
- I think I reported this earlier, Enabling/Disabling filters and Showing posts when a group has an active filter causes a 5 second hang. This also happens 100% of the time and with any filter selected. Additionally, opening the filters window, adding, removing, and editing a filter has the same behavior, 5 second hang.

Please let me know if you want any additional details on anything or would like me to try out some ideas.

Thanks,

Jim
chimmyjim
Seasoned User
Seasoned User
 
Posts: 168
Joined: Thu Dec 18, 2008 7:16 pm
Location: Seattle, WA

Registered Newsbin User since: 12/18/08

Re: Version 6.80 Beta 11 Available...

Postby grantboucher » Sun Nov 05, 2017 5:31 am

Unfortunately, the same bug I reported with B10 exists with B11. Namely, upon downloading any new headers (manual or auto), it refuses to update the display in the Watch Topics search windows without a manual RMB/"Show Posts". Reinstalling B9 returns the behavior to normal. This is with the x64 version.

The Last Files and Last Update columns in the Groups List window appear to update normally in all versions.

Again, after headers were downloaded but during the processing stage, you could see the horizontal scroll bar at the bottom of whatever window was currently selected flash for a split second as presumably each new header file was successfully processed and searched and then updated the window. That flash no longer occurs and those windows never refresh their contents.

I have now tested this on multiple computers, all Windows 10 FCU x64, with the same results. However, they shared the same Data directory (across a network in the second case) if that helps.
grantboucher
Occasional Contributor
Occasional Contributor
 
Posts: 24
Joined: Wed Aug 20, 2003 5:07 pm

Registered Newsbin User since: 04/10/03

Re: Version 6.80 Beta 11 Available...

Postby stavros » Mon Nov 06, 2017 1:58 am

Hi,
something I noticed in earlier betas, that is still happening with this one:
The debug log message "DEBUG Checking Autodownload: <group name>" only seems to appear AFTER the corresponding <group name>.gz file has been processed from within the Import directory.

This was most noticable recently when I added a new group and downloaded 5,000,000 headers that went into 5 .gz files of about 43MB each.

I eagerly watched the log and the import directory, waiting for the other group .gz files to be processed and then hit a long pause of several (>5) minutes when the first of the new group .gz files was being processed.
The first .gz file disappeared at the same time as the first "DEBUG Checking Autodownload: <new group name>" appeared in the log.

If I'm seeing this right, I think it would be nice if the message appeared in the log when the .gz file processing starts, so that the group.gz file currently being processed is more easily identifiable (I usually have over 350 groups with multiple .gz files of widely varying sizes to contend with).

regards
Stavros.
stavros
Active Participant
Active Participant
 
Posts: 51
Joined: Wed Dec 24, 2003 2:07 am

Registered Newsbin User since: 12/24/03

Re: Version 6.80 Beta 11 Available...

Postby Quade » Mon Nov 06, 2017 4:15 am

If I'm seeing this right, I think it would be nice if the message appeared in the log when the .gz file processing starts, so that the group.gz file currently being processed is more easily identifiable (I usually have over 350 groups with multiple .gz files of widely varying sizes to contend with).


I could I guess but it doesn't even check if auto-download is enabled till after each GZ is fed. It doesn't auto-download from the GZ's but from the files already fed into the DB.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby stavros » Mon Nov 06, 2017 6:13 am

Sorry Quade, maybe I misunderstood the purpose of the message in the debug log.

I was using it as an indicator that the .gz import mechanism (dbworker?) was processing one of a set of one or more .gz files for a group (depending on how many headers were downloaded for the and maybe split into separate .gz files).
So it seemed that it was appearing too late - after the .gz file for a group was processed, rather than as processing started.

Would it be possible, please, to log the start of processing for each .gz file in the import directory?
or the start of processing of .gz files for a particular group (assuming that all .gz files for a group are processed consecutively, even if added to the import directory at differnt times)?
stavros
Active Participant
Active Participant
 
Posts: 51
Joined: Wed Dec 24, 2003 2:07 am

Registered Newsbin User since: 12/24/03

Re: Version 6.80 Beta 11 Available...

Postby Quade » Mon Nov 06, 2017 11:33 am

I can make it log before processing the GZ then log when it checks auto-mode. Checking automode just means it looks in the configuration file to see if the group has automode enabled.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby stavros » Mon Nov 06, 2017 1:24 pm

Thanks, that would be great.

On another point, is there a way to get a copy of the .gz files before they are deleted? (Sorry if this is the wrong place to ask).
What I'd like to do is run them into another newsbin installation on another of my machines with different (less) retention parameters whilst keeping my main setup as is.
I could just re-download the headers, but that seems awfully inefficient, and I'm loathe to run a process that would jump in and grab a copy whilst newsbin is potentially processing them.

Any advice?

regards
Stavros.
stavros
Active Participant
Active Participant
 
Posts: 51
Joined: Wed Dec 24, 2003 2:07 am

Registered Newsbin User since: 12/24/03

Re: Version 6.80 Beta 11 Available...

Postby kirm » Thu Nov 09, 2017 12:35 am

Today was the first time I got the MOTD "Can't reach this page" with b11. I never had this issue before as some other users reported and with this version that I dl and ran daily since Sat.
kirm
Seasoned User
Seasoned User
 
Posts: 203
Joined: Sun Aug 17, 2003 4:17 pm

Registered Newsbin User since: 05/15/03

Re: Version 6.80 Beta 11 Available...

Postby gkar » Thu Nov 09, 2017 6:24 am

+!
User avatar
gkar
Seasoned User
Seasoned User
 
Posts: 302
Joined: Tue Jun 26, 2012 1:40 pm

Registered Newsbin User since: 06/27/12

Re: Version 6.80 Beta 11 Available...

Postby kenr » Thu Nov 09, 2017 6:36 am

Strange error this morning
[11/09 09:35:31] ERROR SSL Lib returned error: 0xffffffffffffffb4
User avatar
kenr
Seasoned User
Seasoned User
 
Posts: 258
Joined: Wed Mar 27, 2002 6:14 am
Location: Galashiels

Registered Newsbin User since: 04/13/03

Re: Version 6.80 Beta 11 Available...

Postby Quade » Thu Nov 09, 2017 9:39 am

Any advice?


Code: Select all
[SETTINGS]
SaveGZ=1


Instead of deleting them, it'll move them to a "Processed" folder.

Not sure about the connectivity thing. I'll ask Dex. Might be some internet issue.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby PRoyer » Thu Nov 09, 2017 9:50 am

kenr wrote:Strange error this morning
[11/09 09:35:31] ERROR SSL Lib returned error: 0xffffffffffffffb4



Cannot reach the home site either - my NewsBin is crashing whenever I try to do anything, but going to the main page gives a timeout error.
If I allow the error you have to show up (wait a couple of minutes, then it appears), it allows me to load my headers up and perform the downloads though.
PRoyer
n00b
n00b
 
Posts: 3
Joined: Fri Jan 23, 2015 1:47 am

Registered Newsbin User since: 04/06/12

Re: Version 6.80 Beta 11 Available...

Postby Quade » Thu Nov 09, 2017 10:50 am

Newsbin checks to see if there's a new MOTD when it starts. That's probably what this error is.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby kenr » Thu Nov 09, 2017 11:02 am

So it checks even when MOTD is turned OFF?
User avatar
kenr
Seasoned User
Seasoned User
 
Posts: 258
Joined: Wed Mar 27, 2002 6:14 am
Location: Galashiels

Registered Newsbin User since: 04/13/03

Re: Version 6.80 Beta 11 Available...

Postby Quade » Thu Nov 09, 2017 1:03 pm

Turning off the motd just turns off the motd display. I suppose I could do something about that. Normally the MOTD only display when there's something new to display.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby kirm » Thu Nov 09, 2017 7:33 pm

Today was the first time I got the MOTD "Can't reach this page" with b11. I never had this issue before as some other users reported and with this version that I dl and ran daily since Sat.


So far today no issue, wonder if it had anything to do with the internet glitch the other day.
kirm
Seasoned User
Seasoned User
 
Posts: 203
Joined: Sun Aug 17, 2003 4:17 pm

Registered Newsbin User since: 05/15/03

Re: Version 6.80 Beta 11 Available...

Postby stavros » Thu Nov 09, 2017 9:20 pm

>SaveGZ=1

excellent!
Thanks Quade.
stavros
Active Participant
Active Participant
 
Posts: 51
Joined: Wed Dec 24, 2003 2:07 am

Registered Newsbin User since: 12/24/03

Re: Version 6.80 Beta 11 Available...

Postby itimpi » Wed Nov 15, 2017 1:02 pm

I am finding with this beta that if I download a ZIP file containing multiple .nzb files into the NZB auto load folder then the NZB files are not being loaded into the download list (although the zip file does get moved to the Loaded sub-folder). If I extract the NZB files from the zip and put them into the NZB autoload folder then Newsbin loads them up just fine.
The Newsbin Online documentation
The Usenettools for tutorials, useful information and links
User avatar
itimpi
Elite NewsBin User
Elite NewsBin User
 
Posts: 12553
Joined: Sat Mar 16, 2002 7:11 am
Location: UK

Registered Newsbin User since: 03/28/03

Re: Version 6.80 Beta 11 Available...

Postby Quade » Wed Nov 15, 2017 2:37 pm

I'll check it out. Thanks.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby gkar » Fri Nov 17, 2017 7:43 pm

seeing this in NBPro logs whilst importing from sonarr

[11/17 22:35:07] ERROR SB - Failed to feed New NZB to Download list - Could be duplicate.....

download and unrar path are different

all im seeing in sonarr logs is
adding report
report sent
for each nzb

edit. have just duplicated this by adding file from internet search, removing it, then adding from sonarr
User avatar
gkar
Seasoned User
Seasoned User
 
Posts: 302
Joined: Tue Jun 26, 2012 1:40 pm

Registered Newsbin User since: 06/27/12

Re: Version 6.80 Beta 11 Available...

Postby Quade » Sat Nov 18, 2017 1:29 am

Newsbin de-dupes the download list. Sounds like the subsequent NZB was a duplicate. The question is whether things are downloading properly.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Beta 11 Available...

Postby DaveXVI » Wed Nov 22, 2017 8:54 pm

The problem with downloads remaining in the download list after completion appears to be fixed (I didn't try B10, but I guess that was when you fixed it). Thank you.
DaveXVI
Seasoned User
Seasoned User
 
Posts: 231
Joined: Sun Oct 16, 2005 4:47 pm

Registered Newsbin User since: 04/23/04

Re: Version 6.80 Beta 11 Available...

Postby Quade » Thu Nov 23, 2017 12:44 am

B11 and forward are pretty aggressive about removing things from the download list. It's quicker to send things to the failed list too.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 42525
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 4 guests