Slow downloads until W7 restart.

This is the place to help test and discuss Version 6 Beta releases.

Slow downloads until W7 restart.

Postby robbie303 » Sun Apr 15, 2018 5:55 am

I'm not 100% sure this is caused by Newsbin, but here goes....
I run Newsbin 6.80RC7 Built 5054. On W7 with all updates installed. I have a paid account with Eweka.
The problem I'm experiencing is that Newsbin its download speed drops to 500KByte/sec or less.
Restarting Newsbin does not give me back my normal download speed (5MByte/sec)
Restarting W7 does give me my normal download speed.
Newsbin starts giving low download speeds after an unknown time (1 day?)
When Newsbin shows these low download speeds, then Chrome/eMule/uTorrent are able to download with normal speed (5MByte/sec)

I'm sorry that at this moment I do not have more information, but maybe other people recognize this issue?
robbie303
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Sun Oct 30, 2005 8:02 pm
Location: Amsterdam, The Netherlands

Re: Slow downloads until W7 restart.

Postby johnisme » Wed May 02, 2018 9:47 pm

Sounds like your isp is throttling your download speed for news groups.
User avatar
johnisme
Active Participant
Active Participant
 
Posts: 81
Joined: Mon Sep 24, 2007 12:00 am

Registered Newsbin User since: 09/22/07

Re: Slow downloads until W7 restart.

Postby Quade » Wed May 02, 2018 10:53 pm

Yeah, I'd give another server a try too.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43234
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Slow downloads until W7 restart.

Postby robbie303 » Thu May 03, 2018 7:10 am

Thanks for your answers.
My isp is not throttling.
I can get 7MByte/sec download speed, sustained, with Newsbin, for long time, hours, maybe even a day.
But, after a few hours? of downloading, or also after a few days of Newsbin running idle in the background, my Newsbin download goes down to a very fluctuating average of less then 0,5 MByte/sec. All other programs on my W7 PC are then still able to download with high speed. A restart of Newsbin does not solve the slow download. Only a reboot of W7 solves it.
My isp is Eweka btw.... They do not throttle.

So, for example:
- Newsbin downloads a total of 100 GByte on high speed, no problem in a few hours.
- I leave Newsbin idle, running at the background for a few days...
- After that, Newsbin will only download with a very fluctuating average of less then 0,5 MByte/sec.
Last edited by robbie303 on Thu May 03, 2018 9:35 am, edited 3 times in total.
robbie303
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Sun Oct 30, 2005 8:02 pm
Location: Amsterdam, The Netherlands

Re: Slow downloads until W7 restart.

Postby dexter » Thu May 03, 2018 7:51 am

ISPs can throttle bandwidth based on port. So NNTP traffic can get throttled but regular web traffic does not. You can sometimes get around it by running Newsbin on an alternate port. If you are running SSL, try port 443 instead of 563.

Also check your Logging tab for errors, you could get slow datarates if all your downloads are failing, like if you hit a bunch with error number 430.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9424
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Slow downloads until W7 restart.

Postby robbie303 » Thu May 03, 2018 8:23 am

Eweka does not throttle.
But OK, I will wait until Newsbin gets slow, and then test my newsgroup download speed with another program (NZBGet)
Will get back with this info in a few hours/days.
robbie303
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Sun Oct 30, 2005 8:02 pm
Location: Amsterdam, The Netherlands

Re: Slow downloads until W7 restart.

Postby dexter » Thu May 03, 2018 8:33 am

I'm not saying Eweka is throttling you, I'm saying your Internet provider may be. You are getting your Usenet content from Eweka. You access Eweka over the Internet through some Internet provider.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9424
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Slow downloads until W7 restart.

Postby robbie303 » Thu May 03, 2018 9:26 am

My isp is Ziggo..
Ziggo does not throttle newsgroups.
robbie303
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Sun Oct 30, 2005 8:02 pm
Location: Amsterdam, The Netherlands

Re: Slow downloads until W7 restart.

Postby dexter » Thu May 03, 2018 9:48 am

So they say. Nobody admits to it.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9424
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Slow downloads until W7 restart.

Postby robbie303 » Sat May 05, 2018 10:01 am

OK, so I downloaded 50Gbyte of newsfiles on this PC (server) and waited 24 hours.
As described above, my download speed went to low.
I then tried to download with NZBGet. But NZBGet also gave slow download speeds.
Then I tried to download with NZBGet on another PC (Notebook) in the network. This PC was able to immediately get high download speeds.
So, it is not my isp throttling.

Both the Server and the Notebook are running W7 with all updates installed.
After rebooting the server, the download speed returned to high again.
Until now, rebooting the server is the only way to get the download speeds high again.

Next step is that I will not start Newsbin on my server, and then use NZBGet to download 50GByte and then wait for
24 hours to see if NZBGet will induce the same problem as Newsbin does.
robbie303
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Sun Oct 30, 2005 8:02 pm
Location: Amsterdam, The Netherlands

Re: Slow downloads until W7 restart.

Postby dexter » Sat May 05, 2018 10:18 am

robbie303 wrote:I then tried to download with NZBGet. But NZBGet also gave slow download speeds.


I think you proved it is not a Newsbin issue. Sounds like some issue specific to this PC.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9424
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Slow downloads until W7 restart.

Postby robbie303 » Sat May 05, 2018 7:59 pm

OK, I tested some more.
NZBGet shows the same phenomenon:
After downloading several gigs of data, the download speed becomes very low (less then 0,5MByte/sec).
But.... Other programs such as torrents and chrome can get normal download speeds (7Mbyte/sec).
And other PC's on my network can then still download from newsgroups at high speed.
So, it is not a Newsbin problem and not an isp throttling problem

It is a problem only on that PC, getting slow downloads from newsservers, but only after some tenths of gigabyte have been downloaded.
Resetting my router and modem did not help.
Anyone suggestions?
robbie303
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Sun Oct 30, 2005 8:02 pm
Location: Amsterdam, The Netherlands

Re: Slow downloads until W7 restart.

Postby Quade » Sun May 06, 2018 12:57 am

I'd remove any non-microsoft security software, reboot and try some more downloads. I've seen security software leak memory and slow down when messing with usenet because most security software doesn't understand usenet.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43234
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Slow downloads until W7 restart.

Postby robbie303 » Mon May 07, 2018 7:49 am

Immediately when I uninstalled AVG, my usenet download speed jumped high again.
So it looks like AVG was the problem.
I will report back after I have done some more testing.
robbie303
Occasional Contributor
Occasional Contributor
 
Posts: 18
Joined: Sun Oct 30, 2005 8:02 pm
Location: Amsterdam, The Netherlands


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 5 guests