Bad NZB or bug?

This is the place to help test and discuss Version 6 Beta releases.

Bad NZB or bug?

Postby Biship » Mon May 13, 2019 9:29 am

Attached NZB gets to 100% but will not assemble.
Filenames in a.b.goat are not what's in the NZB (nor do they match the filenames in the downloads tab).
The the NZB badly formed or is something going on with newsbin?
This has been occurring often in the last week, but I do not know when exactly it started.

Can't find attach file button.
Biship
Active Participant
Active Participant
 
Posts: 88
Joined: Sun Jul 27, 2003 10:14 am

Registered Newsbin User since: 04/01/03

Re: Bad NZB or bug?

Postby Quade » Mon May 13, 2019 11:41 am

You can email it to ts@newsbin.com.

Do you see anything in the logs?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43638
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Bad NZB or bug?

Postby Biship » Mon May 13, 2019 12:56 pm

Emailed. The debug log is full of stuff, the normal log has nothing.
Biship
Active Participant
Active Participant
 
Posts: 88
Joined: Sun Jul 27, 2003 10:14 am

Registered Newsbin User since: 04/01/03

Re: Bad NZB or bug?

Postby Quade » Tue May 14, 2019 12:35 pm

It downloaded and unrared with no issue here. It's one of the obscured filenames NZB's so, what downloads and the filenames in the NZB don't match up. They download as extensionless files that need to be renamed to the proper filenames during repair.

Someone on IRC reported something like this and his NZB worked for me too. We're investigating why his results and mine aren't the same.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43638
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Bad NZB or bug?

Postby Calahan » Sun Jul 14, 2019 9:56 pm

My 6.81 Final began to pause all rars and started downloading the pars when I double clicked on a nzb file.
So I thought I give the betas a chance.

I tried 6.82b8 down to beta 4, all versions showed a wrong par2 file name and downloaded all rar files as extensionless random named files.
BUT when I double click on the SAME NZB file again after installing 6.82b3 it worked as expected.
All files were named as in the nzb file. I think there is something wrong with the file(name) creation.

You have to watch in the download folder, while the files are downloaded, to see what I mean. If all files are downloaded, they will be renamed and all looks well.
But why should beta 3 create correct filenames with the same nzb!?
Calahan
Active Participant
Active Participant
 
Posts: 99
Joined: Wed May 15, 2013 11:14 am

Registered Newsbin User since: 01/14/12

Re: Bad NZB or bug?

Postby Quade » Sun Jul 14, 2019 10:27 pm

The problem is how they're posted. These days even the PARS don't have proper extensions so Newsbin has to ID what's in the file using a digital signature and apply a PAR2 extension to it so the PAR processing works like it does with sane downloads.

You want to feed these NZB's directly to the download list too. Don't send them to the post listing first.

I'd be using Beta 8 if I was you. It doesn't matter what the download filenames are. All that matters is that the PARS are called pars and that repair can properly rename them. Newsbin makes no effort to rename them from the PAR files till repair because if they rename early, they won't resume properly.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43638
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 2 guests