Version 6.80 Release Candidate 7 Available...

This is the place to help test and discuss Version 6 Beta releases.

Version 6.80 Release Candidate 7 Available...

Postby dexter » Fri Mar 16, 2018 1:39 pm

Fewer changes this time. A good sign we are closer to final release.

Changes in this version:
  • Rebuild without compiler optimizations to fix odd issues with the remote nzb interface
  • Fixed issue with excessively long subjects giving multiple entries in post list (and Search)
  • Fixed issue introduced in RC6 where expanding then collapsing some posts would leave extra lines in the post list
  • Fixed issue with certain NZBs that would not download if first imported into a post list.
  • Fixed new $(RAWSUBJECT) path variable introduced in RC6.
  • Now logs if the "BypassFileCheck" flag is on because it disables file resume on restart.
The full change history and the download link is on the Newsbin Beta Page.

If you find any issues, please reply to this thread or use our Technical Support Contact Form.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9440
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby triskel » Sat Mar 17, 2018 7:28 am

Same problem as with RC 5 and 6: the download of "Downloading Files" doesn't start, unless I move all the list to "Wish List" (and back again to "Downloading Files") or I restart Newsbin.
Reinstalled RC 4: all back to normal.
Sob...
:-(

[Windows 10 64 bit, ver. 10 1079, build 16299.309; 32 Gb RAM, CPU Intel Core i7 6700]
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 7 Available...

Postby Biship » Sat Mar 17, 2018 7:41 am

RC7 gets stuck downloading a newsgroup. It tries every second. Group never leaves 'Downloading Files'. Server overlap is set to 100.

Code: Select all
[03/17 06:38:08]  ERROR Reports Empty Group:alt.binaries.whitburn.lossless news.frugalusenet.com
[03/17 06:38:08]  DEBUG Connecting: news.frugalusenet.com Index:2
[03/17 06:38:08]  DEBUG Connection Status: news.frugalusenet.com SSL Version: TLSv1.2 TLS-RSA-WITH-AES-128-CBC-SHA
[03/17 06:38:08]  DEBUG Connected: news.frugalusenet.com Index:2
[03/17 06:38:08]  DEBUG Stored Range: Min: 0 Max: 0 alt.binaries.whitburn.lossless news.frugalusenet.com
[03/17 06:38:09]  DEBUG Group Numbers: alt.binaries.whitburn.lossless Min: 39525 Max: 39525 news.frugalusenet.com
[03/17 06:38:09]  ERROR Reports Empty Group:alt.binaries.whitburn.lossless news.frugalusenet.com
[03/17 06:38:09]  DEBUG Connecting: news.frugalusenet.com Index:2
[03/17 06:38:09]  DEBUG Connection Status: news.frugalusenet.com SSL Version: TLSv1.2 TLS-RSA-WITH-AES-128-CBC-SHA
[03/17 06:38:09]  DEBUG Connected: news.frugalusenet.com Index:2
[03/17 06:38:09]  DEBUG Stored Range: Min: 0 Max: 0 alt.binaries.whitburn.lossless news.frugalusenet.com
[03/17 06:38:09]  DEBUG Group Numbers: alt.binaries.whitburn.lossless Min: 39525 Max: 39525 news.frugalusenet.com
[03/17 06:38:09]  DEBUG NZB File Load Checking
[03/17 06:38:09]  ERROR Reports Empty Group:alt.binaries.whitburn.lossless news.frugalusenet.com
[03/17 06:38:09]  DEBUG Connecting: news.frugalusenet.com Index:2
[03/17 06:38:09]  DEBUG Connection Status: news.frugalusenet.com SSL Version: TLSv1.2 TLS-RSA-WITH-AES-128-CBC-SHA
[03/17 06:38:09]  DEBUG Connected: news.frugalusenet.com Index:2
[03/17 06:38:09]  DEBUG Stored Range: Min: 0 Max: 0 alt.binaries.whitburn.lossless news.frugalusenet.com
[03/17 06:38:09]  DEBUG Group Numbers: alt.binaries.whitburn.lossless Min: 39525 Max: 39525 news.frugalusenet.com
Biship
Active Participant
Active Participant
 
Posts: 74
Joined: Sun Jul 27, 2003 10:14 am

Registered Newsbin User since: 04/01/03

Re: Version 6.80 Release Candidate 7 Available...

Postby Quade » Sat Mar 17, 2018 10:48 am

RC7 gets stuck downloading a newsgroup. It tries every second. Group never leaves 'Downloading Files'. Server overlap is set to 100.


Yeah, this seems like a legit bug. The group is reported as empty by the server but isn't being removed from the download list. You might want to uncheck this group for now. Dex tells me there hasn't been a meaningful post to the group since 2016.

Same problem as with RC 5 and 6: the download of "Downloading Files


We're at this point in the RC cycle because it's working for most people. I've pumped an easy 100 gigs through just this RC7 so, the question Dex and I are wondering about is why you're having this issue and we aren't. I'm not denying your experience. We just don't know why it's happening. Another user also has odd problems but his odd problems aren't the same as yours.

If you want to try to trouble-shoot this, the first thing I'd do is, from the options "Open Data Folder" then close Newsbin. I'd start be deleting "downloadsv2.db3" and "downloaded.db3" . This will purge the download, wish, failed and files list. Then try again. How are you downloading Headers, Search or NZB files?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43309
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby triskel » Sat Mar 17, 2018 10:56 am

triskel wrote:Same problem as with RC 5 and 6: the download of "Downloading Files" doesn't start, unless I move all the list to "Wish List" (and back again to "Downloading Files") or I restart Newsbin.
Reinstalled RC 4: all back to normal.
Sob...
:-(

[Windows 10 64 bit, ver. 10 1079, build 16299.309; 32 Gb RAM, CPU Intel Core i7 6700]



Anything about my problem?
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 7 Available...

Postby Quade » Sat Mar 17, 2018 10:57 am

Maybe you need to refresh the page.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43309
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby triskel » Sat Mar 17, 2018 11:00 am

Opppsss... Sorry! :oops:
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 7 Available...

Postby triskel » Sat Mar 17, 2018 11:04 am

It happens downloading new headers from a group, searching or using nzb.
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 7 Available...

Postby Biship » Sat Mar 17, 2018 11:07 am

Quade wrote:
RC7 gets stuck downloading a newsgroup. It tries every second. Group never leaves 'Downloading Files'. Server overlap is set to 100.


Yeah, this seems like a legit bug. The group is reported as empty by the server but isn't being removed from the download list. You might want to uncheck this group for now. Dex tells me there hasn't been a meaningful post to the group since 2016.



Ok, yeah the group seems dead. I'll just uncheck for now, but want to keep the group just in case anyone ever posts anything I'm looking for. Thanks!
Biship
Active Participant
Active Participant
 
Posts: 74
Joined: Sun Jul 27, 2003 10:14 am

Registered Newsbin User since: 04/01/03

Re: Version 6.80 Release Candidate 7 Available...

Postby mimauk » Sat Mar 17, 2018 6:44 pm

RC7 - just noticed that the number in parenthesis for the cache seems to be stuck at 9 - Cache:1000/1000 (9) with nothing in the download list. Even after shutting NB down for an hour or so, when I restart it the 9 reappears after a few seconds.
mimauk
Seasoned User
Seasoned User
 
Posts: 275
Joined: Sun Aug 20, 2006 12:35 pm

Registered Newsbin User since: 03/29/06

Re: Version 6.80 Release Candidate 7 Available...

Postby dexter » Sat Mar 17, 2018 6:48 pm

This means it got stuck importing header data. If you go under Options -> Settings and click "Open Data Folder" then go into the Import folder, you'll see the files Newsbin is trying to process. You can close Newsbin and delete those files and the number will go to (0) but you will lose that header data. You could try deleting one of the files and see if Newsbin is able to continue. Do this when Newsbin is closed.

If it happens alot, you should configure your antivirus software to not scan the Newsbin Data Folder. Sometimes it can corrupt the data and cause problems like this.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9440
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby Quade » Sat Mar 17, 2018 7:44 pm

One of the reasons I switched to .txt files is that they're less likely to be touched by a Virus scanner. I'm wondering if you just have some left over files in the import folder that Newsbin is counting?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43309
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby kirm » Sat Mar 17, 2018 10:02 pm

This means it got stuck importing header data. If you go under Options -> Settings and click "Open Data Folder" then go into the Import folder, you'll see the files Newsbin is trying to process. You can close Newsbin and delete those files and the number will go to (0) but you will lose that header data. You could try deleting one of the files and see if Newsbin is able to continue. Do this when Newsbin is closed.


I recall having this issue due to spammers. The best thing to do is move them to another temp folder while Newsbin is running. The ones that remain are causing the issue for the count. Close Newsbin down, delete those txt files in the import folder, and then you can move the items that you originally moved to the temp folder back in to the import folder and they should just run through. That way you will not lose as many headers. Also narrows down the group that is having the issue.
kirm
Seasoned User
Seasoned User
 
Posts: 225
Joined: Sun Aug 17, 2003 4:17 pm

Registered Newsbin User since: 05/15/03

Re: Version 6.80 Release Candidate 7 Available...

Postby syshog » Sun Mar 18, 2018 2:31 am

kirm wrote:
This means it got stuck importing header data. If you go under Options -> Settings and click "Open Data Folder" then go into the Import folder, you'll see the files Newsbin is trying to process. You can close Newsbin and delete those files and the number will go to (0) but you will lose that header data. You could try deleting one of the files and see if Newsbin is able to continue. Do this when Newsbin is closed.


I recall having this issue due to spammers. The best thing to do is move them to another temp folder while Newsbin is running. The ones that remain are causing the issue for the count. Close Newsbin down, delete those txt files in the import folder, and then you can move the items that you originally moved to the temp folder back in to the import folder and they should just run through. That way you will not lose as many headers. Also narrows down the group that is having the issue.


When I had this problem in RC5 the moving the files trick didn't help. I have full drive exceptions set in my AV for the NB data drive and NB program folder. My advice to people this don't want to hose their headers is to make a a full data folder w/header backup between switching versions of NB. I have 2.8TB worth of headers to backup now days. I've experience funky problems since version 6.60-6.80.RC5. Version 6.56 was the most rock solid since the switch from 6.40s, but it lacks updated rar and memory usage features. 6.80RC6 worked well, but a week's worth of testing only goes so far. This problem is very hard to duplicate and it drives me nuts.
system:
xeon with 64GB of ram and a lot of storage.
User avatar
syshog
Seasoned User
Seasoned User
 
Posts: 107
Joined: Sun Jun 18, 2006 7:26 pm

Registered Newsbin User since: 06/17/06

Re: Version 6.80 Release Candidate 7 Available...

Postby mimauk » Sun Mar 18, 2018 6:18 am

dexter wrote:This means it got stuck importing header data. If you go under Options -> Settings and click "Open Data Folder" then go into the Import folder, you'll see the files Newsbin is trying to process. You can close Newsbin and delete those files and the number will go to (0) but you will lose that header data. You could try deleting one of the files and see if Newsbin is able to continue. Do this when Newsbin is closed.

If it happens alot, you should configure your antivirus software to not scan the Newsbin Data Folder. Sometimes it can corrupt the data and cause problems like this.



That worked. There were a couple of files from 3 days ago that were probably causing the problem but I deleted about 10 files that were in the import folder.

Thanks guys.
mimauk
Seasoned User
Seasoned User
 
Posts: 275
Joined: Sun Aug 20, 2006 12:35 pm

Registered Newsbin User since: 03/29/06

Re: Version 6.80 Release Candidate 7 Available...

Postby syshog » Tue Mar 20, 2018 2:25 pm

I had this problem again this time on RC7. I was using a fresh header load on a new USP using only a single group a.b.u-4all I was only downloading 100 days. I have two files stuck in the import folder totaling 392MB. I know that they were never processed because I had Windows resource monitor open the whole time disk i could track the the writing to disk. When the last two files appeared in the import folder all disk write activity stopped on the spool_v6\alt.binaries.u-4all\storage.db3 file. The log didn't go past the files processed before the last two files entered in the import folder. I left the computer on over night with NB 6.80RC7 open while I slept. The hard drives when idle right after the the activity stopped. I can open and close NB but the cache will remain (2) and never start the processing them. I'd like to be able to troubleshoot this more, but nothing else is showing up on the logs and I'll go back to an older version of NB for the time being.
system:
xeon with 64GB of ram and a lot of storage.
User avatar
syshog
Seasoned User
Seasoned User
 
Posts: 107
Joined: Sun Jun 18, 2006 7:26 pm

Registered Newsbin User since: 06/17/06

Re: Version 6.80 Release Candidate 7 Available...

Postby dexter » Tue Mar 20, 2018 3:03 pm

syshog wrote:I was only downloading 100 days.


Haha, I just tried this and it equates to 200 million headers. I'll let it run and see if I can recreate your issue.

How about holding on to those files that got stuck in the Import folder? If I can't recreate, we could maybe try to import them here.

Also wondering if your storage.db3 file got corrupted. Do you have your antivirus software set to ignore the Newsbin data folder? With that much activity writing to the .db3, AV software could cause a conflict.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9440
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby Quade » Tue Mar 20, 2018 4:55 pm

If the files don't end in "txt" or "gz" they won't get imported. You can just delete them or wait for Newsbin to eventually delete them.

It typically indicates you had a connection failure so that particular block of headers didn't complete. It should have been retried and eventually downloaded.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43309
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby syshog » Fri Mar 23, 2018 2:47 am

dexter wrote:
syshog wrote:I was only downloading 100 days.


Haha, I just tried this and it equates to 200 million headers. I'll let it run and see if I can recreate your issue.

How about holding on to those files that got stuck in the Import folder? If I can't recreate, we could maybe try to import them here.

Also wondering if your storage.db3 file got corrupted. Do you have your antivirus software set to ignore the Newsbin data folder? With that much activity writing to the .db3, AV software could cause a conflict.


The data folder (including headers) is on it's own drive and the whole drive has AV exceptions set to it. The folder were the newsbin program files are installed also have AV exceptions. I make backup of my headers once a week or at least try to, so I just nuke and retest with older NB to see if I run into any problems and then I upgrade to any beta or RC to try to reproduce any difficulties. I should add any group that was a trouble maker I tend to load into memory upon recovery on backup to test for corruption issues. In this case is was a fresh load of the group of the past 100 because I wanted to see if they had a file I wanted, It didn't. I had the headers load prior to the last two files being created and I believe it was a week and half missing. I ended up nuking it, but I always re-run the test it another rc or beta.


Quade the files in question were .txt. The log only shows the current session which gives nothing and the backup only shows the previous active session. I had opened and closed NB a few times. Could you include the amount of days to log as an option? I can't always reduce this problem.
system:
xeon with 64GB of ram and a lot of storage.
User avatar
syshog
Seasoned User
Seasoned User
 
Posts: 107
Joined: Sun Jun 18, 2006 7:26 pm

Registered Newsbin User since: 06/17/06

Re: Version 6.80 Release Candidate 7 Available...

Postby Quade » Fri Mar 23, 2018 1:42 pm

Quade the files in question were .txt. The log only shows the current session which gives nothing and the backup only shows the previous active session. I had opened and closed NB a few times. Could you include the amount of days to log as an option? I can't always reduce this problem.


If you're hitting a spammy group, it might just take a really long time to process too. Dex pointed out a group to me the other day. People were posting 100's of thousands of posts that simply couldn't be turned into files without the NZB. The only thing you could do with those posts was throw them away.

I never ever backup my headers and I've not gotten a corrupt one in forever. Then again I only use the MS AV software and firewall. It's the only software I trust not to F things up.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43309
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

mouse pointer jumps when doing a click & drag to highlight

Postby skoolrumble » Tue Apr 03, 2018 11:19 pm

Not sure if it's been mentioned before, but I've been having this problem with highlight with a mouse in newsbin since the last few versions. I'm currently on 6.80 RC7-5054. But I also seem to recall it happening with the last non-beta official releases.

A rather annoying bug:
When I click and drag in most of the windows that have a horizontal scroll bar, the pointer will jump someplace else. This happens to windows like: Downloading Files, NZB files, Logging, Search, etc. It will stop if I minimize the columns to that there's no horizontal scroll bar. And it also doesn't happen if the horizontal scroll bar is all the way to the right; but if the bar is anywhere else, the pointer jumps when I click & drag.


There's also been a problem with how long it takes from when I change the position of something downloading (e.g. moving something to the top) to when it actually takes effect (it seem to take like over 5-15 minutes?).

Regarding toolbar customization: can we also get the ability to add things that are in the Options (e.g. Diable Autopar, toggling the Auto Download for double-clicked NZBs, etc.).

Thanks for your hard work at this product, Dexter!
Last edited by skoolrumble on Thu Apr 05, 2018 12:13 am, edited 1 time in total.
skoolrumble
Active Participant
Active Participant
 
Posts: 51
Joined: Tue Jul 25, 2006 3:47 am

Registered Newsbin User since: 07/26/06

Re: Version 6.80 Release Candidate 7 Available...

Postby mister_loaf » Wed Apr 04, 2018 12:05 am

Every time I start RC-7 it pops up the "Message of the Day" window even though I have that unchecked in settings.

When I click on the "Newsbin Beta Page" link in the Message of the Day window, it launches Internet Explorer instead of my default browser.
mister_loaf
Occasional Contributor
Occasional Contributor
 
Posts: 13
Joined: Mon Sep 04, 2017 11:03 pm

Registered Newsbin User since: 08/30/17

Re: Version 6.80 Release Candidate 7 Available...

Postby Quade » Wed Apr 04, 2018 12:05 pm

Go into the help menu, "register update key" and then re-submit the key. I think Newsbin thinks it's unregistered.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43309
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby KingFish » Wed Apr 04, 2018 5:05 pm

The Path Item Definition of $(GOG) is displayed as "Video Resolution extracted from the subject"

Options -> Settings -> Basic Settings -> Main Download Folder: -> Change -> Edit Path

Image

Is it the same for everyone else?
MS Windows 10 Pro 64-Bit - ASUS P8Z77-V LE; Intel i7-3770K 3.5 GHz; 16.0GB DDR3; EVGA GeForce GTX 1050TI; Kingston 120GB SATA III SSD; 6 X HGST 3TB 7200RPM 6.0Gb/s SATA III.
User avatar
KingFish
Seasoned User
Seasoned User
 
Posts: 394
Joined: Mon Aug 13, 2001 5:17 pm

Registered Newsbin User since: 05/17/03

Re: Version 6.80 Release Candidate 7 Available...

Postby Quade » Thu Apr 05, 2018 12:26 am

Dex drew my attention to this. I have an action item to check it. I thought it was an off by one error but it looks much worse than that.

Thanks.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43309
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 7 Available...

Postby AFriend » Tue Apr 10, 2018 9:43 am

After install of RC5, RC6 or RC7 I get a Windows Defender hit (Windows 10, latest update) on C:\Program Files\Newsbin\Uninst64.exe
Trojan:Script/Cloxer.D!cl (severe).
(Re)install of RC4 does not give this error, so seems to be in RC5-7 only.
After a while also the CPU for NewsBinPro process goes to 95% and higher constantly, also when pausing download. Downloads of install files came directly from http://www.newsbin.com/beta.php site. Full system scan after quarantine (also with HitManPro anti virus scanner) gives no other issues.
This seems troublesome.
AFriend
n00b
n00b
 
Posts: 1
Joined: Wed Jun 08, 2011 3:32 pm

Registered Newsbin User since: 01/24/11

Re: Version 6.80 Release Candidate 7 Available...

Postby _DonB_ » Sun Apr 15, 2018 2:40 pm

Trying the newest RC 7, but there is still a problem I've been having since the last version. Pausing or clicking "Activate the speed limiter" causes downloads to continue or revert to full speed after several seconds. Network settings show "Use Pause Time-out" and "Use Speed Limit Time-out" as unchecked, and "Speed Limiter" as checked. When downloads revert to full speed, the "Speed Limiter" shows as unchecked, but I did not change it manually.
_DonB_
Occasional Contributor
Occasional Contributor
 
Posts: 10
Joined: Sun Oct 01, 2006 9:37 am
Location: Indiana

Registered Newsbin User since: 05/07/06


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 11 guests