Sonarr link not working.

There is no such thing as a stupid question here as long as it pertains to using NewsBin. Newbies feel free to get help getting started or asking questions that may be obvious. Regular users are asked to be gentle. :-)

Moderators: Quade, dexter

Sonarr link not working.

Postby SykesIT » Sat Oct 17, 2020 10:00 am

I am having an issue connecting the Newsbin to Sonarr and Radarr.

I have latest version of all software and working fine with NZBGet but can't get Newsbin to work just failed.

I have attached logs from Sonarr at top.

Anybody else having this issue.

Sonarr Debug Log:
Links not allowed for unregistered users

Sonarr Log:
20-10-17 13:40:38.8|Error|Sabnzbd|Test aborted due to exception

[v2.0.0.5344] NzbDrone.Core.Download.Clients.DownloadClientException: Error response received from SABnzbd:
at NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdProxy.CheckForError(HttpResponse response) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Sabnzbd\SabnzbdProxy.cs:line 225
at NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdProxy.ProcessRequest(HttpRequestBuilder requestBuilder, SabnzbdSettings settings) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Sabnzbd\SabnzbdProxy.cs:line 195
at NzbDrone.Core.Download.Clients.Sabnzbd.SabnzbdProxy.GetFullStatus(SabnzbdSettings settings) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Sabnzbd\SabnzbdProxy.cs:line 102
at NzbDrone.Core.Download.Clients.Sabnzbd.Sabnzbd.<GetCategories>d__10.MoveNext() in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Sabnzbd\Sabnzbd.cs:line 223
at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
at NzbDrone.Core.Download.Clients.Sabnzbd.Sabnzbd.TestCategory() in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Sabnzbd\Sabnzbd.cs:line 433
at NzbDrone.Core.Download.Clients.Sabnzbd.Sabnzbd.Test(List`1 failures) in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\Clients\Sabnzbd\Sabnzbd.cs:line 275
at NzbDrone.Core.Download.DownloadClientBase`1.Test() in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Download\DownloadClientBase.cs:line 116

20-10-17 13:40:38.8|Warn|NzbDroneErrorPipeline|Invalid request Validation failed:
-- Test was aborted due to an error: Error response received from SABnzbd:

Newbin Log:
[10/17 13:57:01] DEBUG User-Agent: Sonarr/2.0.0.5344 (windows 10.0.19041.0)
[10/17 13:57:01] DEBUG Accept: application/json
[10/17 13:57:01] DEBUG Host: localhost:9090
[10/17 13:57:01] DEBUG Accept-Encoding: gzip
[10/17 13:57:01] DEBUG Connection: Close
[10/17 13:57:01] DEBUG SbServer: Read Request GET /api?mode=fullstatus&skip_dashboard=1&apikey=abcd&output=json HTTP/1.1
[10/17 13:57:01] DEBUG GET /api?mode=fullstatus&skip_dashboard=1&apikey=abcd&output=json HTTP/1.1
SykesIT
n00b
n00b
 
Posts: 3
Joined: Sun Oct 11, 2020 2:25 pm

Re: Sonarr link not working.

Postby Quade » Mon Oct 19, 2020 10:34 am

I just installed Sonarr on a windows laptop then added Newsbin as a download client using the SAB template. It tested and I was able to save it.

[10/17 13:57:01] DEBUG SbServer: Read Request GET /api?mode=fullstatus&skip_dashboard=1&apikey=abcd&output=json HTTP/1.1


My "Test" never showed this message. If you have another PC available, I might install Sonarr on it, then configure Newsbin as a downloader then try testing.

I did my testing with 6.82.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Sonarr link not working.

Postby SykesIT » Mon Oct 19, 2020 10:44 am

Hi what settings did you use on newsbin?
SykesIT
n00b
n00b
 
Posts: 3
Joined: Sun Oct 11, 2020 2:25 pm

Re: Sonarr link not working.

Postby SykesIT » Mon Oct 19, 2020 11:30 am

I get the exact same message on a laptop with latest versions of all software installed.

Are you using same Windows10 version.

[10/19 15:28:25] DEBUG User-Agent: Sonarr/2.0.0.5344 (windows 10.0.18363.0)
[10/19 15:28:25] DEBUG Accept: application/json
[10/19 15:28:25] DEBUG Host: localhost:9000
[10/19 15:28:25] DEBUG Accept-Encoding: gzip
[10/19 15:28:25] DEBUG Connection: Close
[10/19 15:28:25] DEBUG SbServer: Read Request GET /api?mode=fullstatus&skip_dashboard=1&apikey=abcd&output=json HTTP/1.1
[10/19 15:28:25] DEBUG GET /api?mode=fullstatus&skip_dashboard=1&apikey=abcd&output=json HTTP/1.1
SykesIT
n00b
n00b
 
Posts: 3
Joined: Sun Oct 11, 2020 2:25 pm

Re: Sonarr link not working.

Postby Quade » Mon Oct 19, 2020 12:07 pm

Newsbin is listening on 7990 and I'm just using an API key. I could try cleaning out all of the sonarr config in Newsbin and trying again.

Ok good news I guess. I was able to reproduce the problem. I'll figure out what configuration item is causing the problem. Cleaning out my existing configuration made it fail.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Sonarr link not working.

Postby Quade » Mon Oct 19, 2020 12:18 pm

Ok I have a work around. You need to pick an UnRAR folder when you configure this in Newsbin. Apparently the "Test" interface is expecting it. You need to make sure to unrar into a folder NOT within the folders managed by Sonarr.

I wrote a note to fix this in the next beta.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to Newbie Forum

Who is online

Users browsing this forum: No registered users and 0 guests