6.82 Lost server and groups

Technical support and discussion of Newsbin Version 6 series.

6.82 Lost server and groups

Postby Heronjr » Tue Aug 31, 2021 11:03 am

Hello,
I have been using Newsbin for years and this is the first time such thing happened: I did not change any settings nor installed anything in my desktop during the last weeks, and today, out of the blue, when opening Newsbin, it first sent me a message in a window saying "No server - Newsbin needs a server...". Then, in the main interface, although showing my layout, I saw that my groups were all gone, so I had to reconfigure my server and search my groups, which is kind of a hard job, as I really can't remember the exact group names.

Any ideas?
Thanks and regards
Heron Jr
Heronjr
n00b
n00b
 
Posts: 7
Joined: Tue Aug 08, 2017 4:04 pm

Re: 6.82 Lost server and groups

Postby Quade » Tue Aug 31, 2021 11:05 am

In the options menu you can pick "Load backup Configuration on Restart" and see if you can load an older copy of the configuration. This should work as long as you haven't started Newsbin too many times since whatever broke broke.

The configuration is typically stored in the data folder in a file called "Newsbin.nbi". It sounds like something took out that file.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44578
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.82 Lost server and groups

Postby Heronjr » Tue Aug 31, 2021 12:21 pm

Thanks. It worked. Now I know and will backup this file.

Regards
Heron Jr
Heronjr
n00b
n00b
 
Posts: 7
Joined: Tue Aug 08, 2017 4:04 pm

Re: 6.82 Lost server and groups

Postby drake00 » Thu Dec 16, 2021 9:19 pm

Same thing happened to me today, running 6.90RC3. I followed Wade's advice and everyhting is perfect now, nevertheless - why did it happen. No changes to my system in last year.
drake00
n00b
n00b
 
Posts: 3
Joined: Mon Nov 14, 2011 12:31 am

Registered Newsbin User since: 04/26/05

Re: 6.82 Lost server and groups

Postby Quade » Sat Dec 18, 2021 4:40 am

Either something killed the NBI file or something killed the pointer to the NBI file stored in the registry. If your PC ever crashes, I could see data loss.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44578
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: 6.82 Lost server and groups

Postby zork » Fri Mar 11, 2022 8:03 am

I just upgraded from 6.82 to 6.90 and after upgrade same thing happened. Thought that all my settings were lost but found this topic and got my settings back. Its really handy feature.
zork
Occasional Contributor
Occasional Contributor
 
Posts: 21
Joined: Thu Jul 24, 2014 9:14 am

Registered Newsbin User since: 07/25/14


Return to V6 Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests