Version 6.90 Beta 1 Available...

This is the place to help test and discuss Version 6 Beta releases.

Version 6.90 Beta 1 Available...

Postby dexter » Thu Aug 13, 2020 10:05 am

Yes, it has been 8 months since the last production release. Figured it's about time to start a new beta cycle. Quade has been doing some refactoring of code and has implemented 7zip support. Go to the Beta Page for the download link and to get more details on the changes since 6.90.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9475
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Fisherking » Thu Aug 13, 2020 12:13 pm

Hi,

Filenames in the filelist has black stripes, therefore cannot read. SS Attached

https://ibb.co/WpBkkyV

Thanks
Fisherking
Active Participant
Active Participant
 
Posts: 61
Joined: Tue Oct 24, 2006 3:34 pm

Registered Newsbin User since: 10/24/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Thu Aug 13, 2020 3:09 pm

Are you using remote desktop or something? I've been running this for the last week with no issues like this.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Fisherking » Thu Aug 13, 2020 4:33 pm

Quade wrote:Are you using remote desktop or something? I've been running this for the last week with no issues like this.


No, but is this could be because of the weird Win10 Color Scheme ? Only File list tab is affected, the other tabs are OK.
Fisherking
Active Participant
Active Participant
 
Posts: 61
Joined: Tue Oct 24, 2006 3:34 pm

Registered Newsbin User since: 10/24/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Thu Aug 13, 2020 5:29 pm

I guess it could be. You might check the "Colors" options in the options.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Fisherking » Thu Aug 13, 2020 6:19 pm

Quade wrote:I guess it could be. You might check the "Colors" options in the options.


I've tried that too, it affects only the other columns in the File List Tab.

Filename column is unaffected, ignores the colour & background settings.

Very strange. I'll revert back to previous version as I'm the only one affected so far.
Fisherking
Active Participant
Active Participant
 
Posts: 61
Joined: Tue Oct 24, 2006 3:34 pm

Registered Newsbin User since: 10/24/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Thu Aug 13, 2020 9:13 pm

Just about everyone uses 32 bit colors these days. I wonder if your video options are for something else. Like 16 bit or 24.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Fisherking » Fri Aug 14, 2020 5:58 am

Quade wrote:Just about everyone uses 32 bit colors these days. I wonder if your video options are for something else. Like 16 bit or 24.


Video Options is at 32bit

The color options in NB settings have no effect on my system. I've changed all of the color settings for all of the lists, but affects nothing.

Btw, my system :

Win 10 2004 19041.450
ASUS TUF Gaming X570 Plus
Ryzen 7 3700X ( No Overclock )
16GB RAM DOCP 3600
80TB Storage via DrivePool
Radeon RX580 8GB
Adata NVME as a boot/system
750W PSU
Fisherking
Active Participant
Active Participant
 
Posts: 61
Joined: Tue Oct 24, 2006 3:34 pm

Registered Newsbin User since: 10/24/06

Re: Version 6.90 Beta 1 Available...

Postby kenr » Fri Aug 14, 2020 6:28 am

With the latest one under wine I am getting
ALLAYS Sqlite Error : Reports Unrecoverable error 1
User avatar
kenr
Seasoned User
Seasoned User
 
Posts: 286
Joined: Wed Mar 27, 2002 6:14 am
Location: Galashiels

Registered Newsbin User since: 04/13/03

Re: Version 6.90 Beta 1 Available...

Postby Quade » Fri Aug 14, 2020 9:10 am

Yeah it seems to be some kind of ignore able error. Not sure what's causing is yet
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby mimauk » Fri Aug 14, 2020 9:22 am

Latest Beta - Win10Pro 64 Bit.

When downloading files from a certain poster, with all previous versions of NBPro, an nzb file is always added to the download list. eg.-
File xyz.part1.par 600MB
File xyz.nzb 2kb

With the new Beta it shows as, -
File xyz.part1.par 600MB
File.xyz.part1.par 2kb

The nzb file is being misnamed. It is only with this particular poster that an nzb file is added to the Download list.
mimauk
Seasoned User
Seasoned User
 
Posts: 284
Joined: Sun Aug 20, 2006 12:35 pm

Registered Newsbin User since: 03/29/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Fri Aug 14, 2020 11:46 am

Are you using search or NZB;s? If search, you can IM me a subject to search for to try it.

Downloading NZB's along with the files is pretty pointless so...well I don't know. Are you sure the par isn't a par?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Calahan » Fri Aug 14, 2020 4:33 pm

The new beta still doesn't unpack correctly. It still changes the name of unpacked files.
You can test with any of the latest "Playable"-Releases in a.b.console.ps3.

As I wrote before, that is a dangerous error as it can corrupt any unpacked computer/console programs.
PLEASE don't change folders or files that are unpacked from archives.
Every unpacked file and folder must have exactly the same name as in the archive.
Calahan
Seasoned User
Seasoned User
 
Posts: 109
Joined: Wed May 15, 2013 11:14 am

Registered Newsbin User since: 01/14/12

Re: Version 6.90 Beta 1 Available...

Postby Quade » Fri Aug 14, 2020 10:00 pm

It's the paths are two long Newsbin will strip them down. Is that what you're seeing? Long paths break Sonarr.

I don't know what's wrong with out a specific example. You can PM me the description of the problem with actual names.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Calahan » Sat Aug 15, 2020 2:41 pm

PM sent.

While trying to track down another strange behaviour of Newsbin, I now found out, that I can't download par2 block files of a group. (The par2 files are part of a grouped posting.)
Newsbin shows "Downloaded" but the files are not saved. I also tried to save to an existing and a new folder. New folder was created, but it remained empty.

Update:
I found them. They were deleted to the Recycle Bin.
Calahan
Seasoned User
Seasoned User
 
Posts: 109
Joined: Wed May 15, 2013 11:14 am

Registered Newsbin User since: 01/14/12

Re: Version 6.90 Beta 1 Available...

Postby fidodkk » Sun Aug 16, 2020 6:18 pm

I also getting the same error as kenr, but i can't also not import a any NZB files.

[08/16 23:09:21] ALWAYS Sqlite Error : Reports Unrecoverable error 1
[08/16 23:09:21] ALWAYS Sqlite Error : Reports Unrecoverable error 1
[08/16 23:09:22] HIGH Aggressive Assembly mode: Enabled
[08/16 23:09:22] HIGH PAR Pausing: Disabled
[08/16 23:09:22] HIGH Par2Repair - Multi-core 3.2
[08/16 23:09:22] HIGH MessageId Filter: Disabled
[08/16 23:09:22] ERROR Thread Died: NZB Loader
[08/16 23:12:13] ALWAYS Sqlite Error : Reports Unrecoverable error 1
[08/16 23:12:13] ALWAYS Sqlite Error : Reports Unrecoverable error 1
[08/16 23:13:46] ALWAYS Sqlite Error : Reports Unrecoverable error 1
[08/16 23:13:46] ALWAYS Sqlite Error : Reports Unrecoverable error 1
fidodkk
n00b
n00b
 
Posts: 8
Joined: Sun Apr 08, 2018 8:49 pm
Location: Denmark

Re: Version 6.90 Beta 1 Available...

Postby Quade » Sun Aug 16, 2020 7:43 pm

In the options select "Open Data Folder" then go into "Spool_V6" and delete the "Nzbs" folder. Delete "Basic_Search" while you're at it. See if NZB loading works. Modern NZB's should be sent directly to the download list these days. No through the post list, then the download list.

Note what folder the data folder it and tell me. It almost sounds like the data folder is "read only".
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby fidodkk » Sun Aug 16, 2020 8:13 pm

Spool_V6 is emty, i have not deleted anything and there is no Basic_Search.

Yes the data folder is "read only" and i have tried untick it but the folder automatic getting "read only" when i checking the properties again.
fidodkk
n00b
n00b
 
Posts: 8
Joined: Sun Apr 08, 2018 8:49 pm
Location: Denmark

Re: Version 6.90 Beta 1 Available...

Postby Calahan » Sun Aug 16, 2020 9:06 pm

Until yesterday I could load nzb files in Newsbin with a doubleclick in Explorer or other file managers.
Now I saw that none were added to the download list. From 8 nzb files I added yesterday, only two were downloaded.
In the logging tab I see "ERROR Thread Died: NZB Loader"

I went back to 6.82 and it worked again. Installed Beta 1 again and it didn't work.
Will check for the folders you mentioned when the downloads are finished.

So it worked for some days, then something must have happend. But what? And why does 6.82 still work?

Update:
I deleted the folders "Nzbs" and "BASIC_SEARCH" and Beta 1 is accepting nzb files again.
Let's see how long.
Calahan
Seasoned User
Seasoned User
 
Posts: 109
Joined: Wed May 15, 2013 11:14 am

Registered Newsbin User since: 01/14/12

Re: Version 6.90 Beta 1 Available...

Postby BZee » Mon Aug 17, 2020 8:28 am

descript.ion not being generated.
I download mainly photos for view with ACDSee so I use the descript.ion files extensively. I found the stuff I downloaded using NB6.90b1 doesn't have the associated .ion files.
I re-downloaded some using NB6.82 with the same .nbi file and the descript.ion files are generated.

Edit: looks like the DownloadedFiles.txt file was updated under NB6.90b1. While I'm here it would be great if DownloadedFiles.txt showed the date (time?) of the download.
BZee
Seasoned User
Seasoned User
 
Posts: 447
Joined: Thu Sep 27, 2001 9:10 pm
Location: California

Registered Newsbin User since: 04/13/03

Re: Version 6.90 Beta 1 Available...

Postby Quade » Mon Aug 17, 2020 10:33 am

Update:
I deleted the folders "Nzbs" and "BASIC_SEARCH" and Beta 1 is accepting nzb files again.
Let's see how long.


NZB's in spool_v6 is used when loading to the post list, the list of files. It's not used when feeding NZB's directly to the download list. These days NZB's need to be fed directly to the download list to download properly. Its because of the weird file naming people are using now when posting.

I just double-clicked about 100 gigs of NZB files into the download list using the current beta so, I'm not sure exactly what the issue is. The current version of Newsbin uses the latest Sqlite library. It makes me wonder if some of the databases are old or corrupt and the new version of sqlite is rejecting them.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Quade » Mon Aug 17, 2020 10:35 am

descript.ion not being generated.


I'll note this.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby nethead » Tue Aug 18, 2020 2:45 pm

downloading a file to test the 7zip encountered:
ERROR CNNTPParRepairThread : Unknown Error : Move to Failed

The program created 'copy to folder', no item in the folder (making sense per the Move to Failed)

Not Space Issue (400GB Free)

This same file downloaded last night without issue using v6.8, with the resulting 7zip file left in the Move to folder; that folder was deleted/trash empty before the test above

Update:
Reinstalled v6.8 and downloaded same nzb, no issue dling/file copying
Last edited by nethead on Tue Aug 18, 2020 6:04 pm, edited 1 time in total.
nethead
Occasional Contributor
Occasional Contributor
 
Posts: 43
Joined: Sat Feb 12, 2011 3:03 pm

Registered Newsbin User since: 02/25/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Tue Aug 18, 2020 3:16 pm

If you can PM me an example or send me an NZB to TS@Newsbin.com I can check it out.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby Calahan » Tue Aug 18, 2020 6:14 pm

Just clicked on a nzb file and again it was not loaded.
Log says: ERROR Thread Died: NZB Loader
Looking in the data folder, about two hours ago, there was a new folder "Nzbs" created (containing a "Storage.db3" file).
I again moved the "Nzbs" folder to a backup place. So there is no "Nzbs" folder anymore.
I restarted Newsbin, but the problem still remained.
Last time I installed 6.82 started it and then installed Beta 1 again. So I tried that too, but it didn't help.
I cannot load nzb files with Beta 1 anymore and have to go back to 6.82.
Any Idea?
Calahan
Seasoned User
Seasoned User
 
Posts: 109
Joined: Wed May 15, 2013 11:14 am

Registered Newsbin User since: 01/14/12

Re: Version 6.90 Beta 1 Available...

Postby nethead » Tue Aug 18, 2020 6:37 pm

Quade wrote:If you can PM me an example or send me an NZB to TS@Newsbin.com I can check it out.


Email sent :)
nethead
Occasional Contributor
Occasional Contributor
 
Posts: 43
Joined: Sat Feb 12, 2011 3:03 pm

Registered Newsbin User since: 02/25/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Tue Aug 18, 2020 11:57 pm

Got it. It looks like a split 7zip which contains...rars and maybe PARS. It's going to take awhile to download and test. Does regular 7zip work?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby nethead » Wed Aug 19, 2020 12:20 am

NBP v6.8 downloads/copies the single BIG 7zip file to the extract location without issue; then using standalone 7zip(and/or ExtractNow) it extracts the final file without an issue
nethead
Occasional Contributor
Occasional Contributor
 
Posts: 43
Joined: Sat Feb 12, 2011 3:03 pm

Registered Newsbin User since: 02/25/06

Re: Version 6.90 Beta 1 Available...

Postby triskel » Mon Aug 24, 2020 7:06 pm

So...
August 13: I install the new beta version. Everyting OK.
August 14: the nightmare begins.
I select a group and download latest headers. In the logging tab I can see that there are , but I can't see them in the headers list: it stops at August 13.
Reinstalled version 6.82 final: the problem remains.
I uninstall everything and do a clean reinstall (6.82).
A lot of time to reconfigure everything as before, but nothing change... until August 23.
For no apparent reason everything works again, and I can download the files of the last ten days from the groups of my interest.
August 24 (now, here in Italy): I run Newsbin and the problem is here again: new header in the logging tab, but the header list stops at yesterday.
So I search today's headers using Easynews Web Interface, then i made a search of that files using Newsbin: they are there and I can download them; but simply updating the same groups my headers list stops at yesterday...
HELP! :| :(
User avatar
triskel
Active Participant
Active Participant
 
Posts: 70
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.90 Beta 1 Available...

Postby Calahan » Tue Aug 25, 2020 3:54 pm

If you did a clean install with a new empty database and got no new headers then I would think it's a news server related problem.
Why don't you install another Newsreader and if it has the same problem, it's your news provider.
Calahan
Seasoned User
Seasoned User
 
Posts: 109
Joined: Wed May 15, 2013 11:14 am

Registered Newsbin User since: 01/14/12

Re: Version 6.90 Beta 1 Available...

Postby Quade » Tue Aug 25, 2020 3:56 pm

If you did a clean install with a new empty database and got no new headers then I would think it's a news server related problem.


Yeah makes me wonder if the group stopped updating. Particularly since 6.82 had the same symptoms.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby triskel » Tue Aug 25, 2020 4:39 pm

Thanks to one or two old posts in this forum, maybe I have found a solution.
I noticed that the "Chunk cache use state" was displayed as 400/400 (1200) and the disk was endlessly spinning.
In the Newsbin data folder, I have deleted the content of the "Chunks" and the "Import" folder an now everything works fine (I cross my fingers...).
User avatar
triskel
Active Participant
Active Participant
 
Posts: 70
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.90 Beta 1 Available...

Postby Calahan » Wed Aug 26, 2020 1:41 pm

You wrote you did a clean install. But you didn't delete your old installation.
Seems the import folder was still full of header files and Newsbin needed all those days to import them.
Then After Aug.23 all worked well again, because the header files were imported then.

Everytime you download headers, header files are created in the import folder.
These are imported to the group databases file by file.
You had 1200 header import files waiting for import (the number in brackets).
That's the reason you couldn't see the new header updates.
Calahan
Seasoned User
Seasoned User
 
Posts: 109
Joined: Wed May 15, 2013 11:14 am

Registered Newsbin User since: 01/14/12

Re: Version 6.90 Beta 1 Available...

Postby depredador » Sun Aug 30, 2020 4:28 am

kenr wrote:With the latest one under wine I am getting
ALLAYS Sqlite Error : Reports Unrecoverable error 1

Same.
depredador
Seasoned User
Seasoned User
 
Posts: 118
Joined: Sat Sep 20, 2008 11:49 pm
Location: Australia

Registered Newsbin User since: 09/25/08

Re: Version 6.90 Beta 1 Available...

Postby Quade » Sun Aug 30, 2020 12:56 pm

ALLAYS Sqlite Error : Reports Unrecoverable error 1


It's just a spurious error. I've already taken care of it for the next beta.

Thanks.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby fidodkk » Mon Aug 31, 2020 5:11 pm

Sounds good, i can't wait.
fidodkk
n00b
n00b
 
Posts: 8
Joined: Sun Apr 08, 2018 8:49 pm
Location: Denmark

Re: Version 6.90 Beta 1 Available...

Postby jcthorne » Mon Sep 07, 2020 3:08 pm

I have had quite a number of downloads fail this week due to 7z processing not working. The files have extensions .001 through .xxx

Manually unzipping starting with the .001 file works fine and the result video file is assembled. Newsbin reports the download as failed to Sonarr and Sonarr does a new search and finds a lessor quality one to download. Seems newsbin is not attempting to assemble the files using 7z.
jcthorne
Active Participant
Active Participant
 
Posts: 59
Joined: Sat Nov 01, 2003 12:17 pm

Registered Newsbin User since: 11/01/03

Re: Version 6.90 Beta 1 Available...

Postby Quade » Mon Sep 07, 2020 4:53 pm

The files have extensions .001 through .xxx


Thanks for the report.

Yeah it seems to be some flaw in the 7zip code I'm using. Not 7zip itself but the way it's being triggered. I have a fix for it already which will be in the next beta. Someone sent me one of these NZB's and they aren't like normal split files in that the files have random sizes. I'm not sure but I think the current failures are related to that.

I just worked around the whole issue so split files appear to be a single 7z file to the decoder without first having to combine them which on 60 gigs files would be terribly slow.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby jcthorne » Sun Sep 13, 2020 11:03 am

Getting a new error today.

ERROR Thread Died: Sab Thread

After this occurs, Sonarr, Radarr and Lidarr can no longer communicate with Newsbin until I shut down newsbin and restart. Comms work again for a while and the error happens again.

Any idea where I can look for what is causing this or ideas how to fix?
jcthorne
Active Participant
Active Participant
 
Posts: 59
Joined: Sat Nov 01, 2003 12:17 pm

Registered Newsbin User since: 11/01/03

Re: Version 6.90 Beta 1 Available...

Postby Quade » Sun Sep 13, 2020 12:07 pm

If the NZB's contain passwords, it might be the same NZB loading issue others have had. I'd probably switch back to 6.82 till the next beta drops.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby gonzalu » Wed Sep 23, 2020 9:54 am

Quick feedback...

After installing the new beta, my downloads crawled to kilobits per second and I could not figure out why... no obvious errors or other contributing factors... switched back to 6.82 and all back to normal. Not sure what may have happened.

FYI: The downloads were added under the beta, not under 6.82 and then continued under beta. I did not try starting downloads under 6.82 and continuing under beta.

Looking forward to next release.
User avatar
gonzalu
Occasional Contributor
Occasional Contributor
 
Posts: 16
Joined: Sun Jan 03, 2010 3:35 pm

Registered Newsbin User since: 04/02/09

Re: Version 6.90 Beta 1 Available...

Postby FrizzleFry » Fri Sep 25, 2020 5:33 am

Fisherking wrote:Hi,

Filenames in the filelist has black stripes, therefore cannot read. SS Attached

https://ibb.co/WpBkkyV

Thanks

I see this as well with 6.90 beta 1.

If I click on filenames they become visible but with a black background but then if I click on empty space in the file list the previously clicked filename and its date field turn black.

In case this helps these are my settings in Colors:
custom
Windows mode: dark
app mode: light
transparency: on
Accent color
automatically pick accent color from background unchecked
I have one of the Windows colors picked for accent: a light purple which is on row 3, col 3
show accent color on
start, taskbar, and action center unchecked
title bars and window borders checked

running Windows 10 Home version 2004 64 bit
User avatar
FrizzleFry
Seasoned User
Seasoned User
 
Posts: 694
Joined: Sun Oct 09, 2005 12:04 am

Registered Newsbin User since: 05/04/03

Re: Version 6.90 Beta 1 Available...

Postby Quade » Fri Sep 25, 2020 9:32 am

I'm not sure what would cause that at this point. It does see, like some background is being mapped to black. I'll have to try to reproduce. Thanks.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby chefjoe » Wed Sep 30, 2020 3:52 am

jcthorne wrote:Getting a new error today.

ERROR Thread Died: Sab Thread

After this occurs, Sonarr, Radarr and Lidarr can no longer communicate with Newsbin until I shut down newsbin and restart. Comms work again for a while and the error happens again.

Any idea where I can look for what is causing this or ideas how to fix?


I wanted to report that I'm seeing the same thing in Beta1 with just Sonarr hooked into newsbin as the dl client. Moving back to 6.82 fixed it enough to download the file, but then it became a failed file when it couldn't locate a password. Oddly, when I opened the nzb file in notepad it did have a password in it that I was able to manually enter into the password database and then it was able to extract ok.
chefjoe
Occasional Contributor
Occasional Contributor
 
Posts: 12
Joined: Tue Jan 01, 2013 4:53 am

Registered Newsbin User since: 01/27/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Thu Oct 01, 2020 5:30 pm

Oddly, when I opened the nzb file in notepad it did have a password in it that I was able to manually enter into the password database and then it was able to extract ok.


Could you email that NZB to ts@Newsbin.com? I'd like to look at the embedded password. Normally the password is embedded in the filename. Not sure I support one embedded inside the meta. Want to make sure I do.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby knuffel_u » Mon Oct 05, 2020 9:57 pm

for your info

After i installed the new beta... i got same as a lot of users here have too

thread died nsb loader...

i did what was suggested to delete those 2 folders and removed read only from the datafolder and the subs folders and files, tried again but same error.

after that i just reinstalled the last full version 6.82 build 5142 and the problem with the same NZB was gone.
So for sure its not the NZB file, but something in the new beta has changed.

good luck

Running last win 10 pro with all updates
knuffel_u
n00b
n00b
 
Posts: 1
Joined: Mon Feb 18, 2013 1:00 pm

Registered Newsbin User since: 10/10/12

Re: Version 6.90 Beta 1 Available...

Postby TripleDad » Thu Oct 15, 2020 3:48 pm

Hello all

So is the SQLITE issue (which I see in Windows 10) and the NZB Thread death/stop loading of NZB files related?
TripleDad
Active Participant
Active Participant
 
Posts: 63
Joined: Sun Apr 07, 2002 9:15 pm

Registered Newsbin User since: 05/01/03

Re: Version 6.90 Beta 1 Available...

Postby Alex Atkin UK » Sun Oct 18, 2020 10:41 pm

Any idea what ERROR CheckFilename: Error Default Download Path Used::2147500036 is about?

Other than that and 7zip not working (I'm guessing the ERROR CNNTPParRepairThread : Unknown Error : Move to Failed
mentioned above), it seems faster under WINE 5.0 than it ever was before.

Its too early to be sure though as I haven't really hammered the download list, which is usually what causes the UI to freeze as downloads complete an order of magnitude quicker than the UI can refresh and it seems to cause a queuing of UI updates (this has always been an issue under WINE).
User avatar
Alex Atkin UK
Occasional Contributor
Occasional Contributor
 
Posts: 38
Joined: Wed Sep 27, 2006 10:22 pm

Registered Newsbin User since: 06/12/06

Re: Version 6.90 Beta 1 Available...

Postby Quade » Mon Oct 19, 2020 10:12 am

If you typically use NZB's that have passwords, the current beta is broken for you. I'd suggest reverting.

Any idea what ERROR CheckFilename: Error Default Download Path Used::2147500036 is about?


Newsbin is trying to use a download path set in the options but it can't access that path so, it's trying to use the main download folder. Without knowing more it's hard to tell which path is causing you a problem. You might want to look at the configuration file to make sure you don't have a path set to a drive or NAS that changed or no longer exists.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43908
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.90 Beta 1 Available...

Postby bd baker » Mon Oct 19, 2020 12:36 pm

Has anyone reported the Duplicate Detector appears to not be working in this Beta?
bd baker
Active Participant
Active Participant
 
Posts: 57
Joined: Sat Jan 31, 2004 5:43 pm

Registered Newsbin User since: 01/31/04

Next

Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 6 guests